New installation fails with Spring Application context has not been set

My new install of Confluence is up to this page: http://<myserver>/bootstrap/selectsetupstep.action and all I get is A system error has occurred — our apologies!

Cause:

com.atlassian.util.concurrent.LazyReference$InitializationException: java.lang.IllegalStateException: Spring Application context has not been set
    at com.atlassian.util.concurrent.LazyReference.getInterruptibly(LazyReference.java:149)

caused by: java.lang.IllegalStateException: Spring Application context has not been set
    at com.atlassian.spring.container.SpringContainerContext.getComponent(SpringContainerContext.java:48)

 

The server is Windows 2012 R2 with SQL 2014, using a direct JBDC connection

So far I have tried:

  1. copying the bundled jtds jar file to the /lib directory of the installation directory
  2. repeating step 1 using the jar file from the database jbdc drivers (an earlier version)
  3. logging in using the local admin account
  4. resetting the permissions on all the Confluence files and folders to ensure full access (even tried giving 'authenticated users' full control)
  5. checking the connection string in confluence.cfg.xml file
  6. logging into SQL using those credentials, just to check they were correct

Any help would be greatly appreciated. My battle with Confluences has been going on for three days now (in various forms)

 

1 answer

0 vote

This is often caused by ownership.  I'm not sure exactly how to replicate it on Windows, but on a Linux box, you install Confluence as user "root" and plan to run it as "charlie".  So, you log in, check charlie exists, then forget to swap to charlie and run it as root.  The running account creates logs, temporary files, directories and so-on.  Then, you stop it, and later restart it as charlie.  Charlie can't read/write half of the stuff it needs to, and can't even generate the right messages.  So you get this one.

So, first thing to check is that the user you want to run Confluence under has full read/write/execute/delete access to the whole Confluence installation and the data directory (confluence home)

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Kesha Thillainayagam
Posted Apr 13, 2018 in Confluence

We want to hear how your non-technical teams are using Confluence!

Hi Community! Kesha (kay-sha) from the Confluence marketing team here! Can you share stories with us on how your non-technical (think Marketing, Sales, HR, legal, etc.) teams are using Confluen...

2,909 views 27 12
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you