New Server-ID after changing to temporary Confluence-Home directory

I'm in the process of evaluating switching from the internal database to MS SQL. I have read the Migrate to Another Database guide (using method 2), and overall it seems pretty clear.

Now, after I have moved the attachments to the new the home directory, I get a new Server-ID. When opening the Confluence Setup I am requested to enter a license for the new Server-ID (so I'd have to generate a new license). In my case, I have changed the Server-ID under my.atlassian.com, and pasted the new license into the setup.

Later on, I have to import the backup of my data. It redirects me to a progress site, which should show me how far the progress of importing is. Problem is, the page is not refreshing. After a while, I refresh the page, and I get an error (no further description, I guess it's because of the license). On the error page is an label showing the Server-ID (here it shows the original one).

I then restarted Confluence and I've had an working Confluence installation with all the data back in the system. However, I am unsure how proper this upgrade was? Have I done something wrong or should I use this procedure for the productive system?

I am upgrading from 4.1 to 4.3.3

3 answers

1 accepted

This widget could not be displayed.

Hi there,

First and foremost, please note that server id is not tight to your license. So it is not necessary for you to change license because you have a different server id than the one identified on your license profile at my.atlassian.com

Please refer to our documentation here:

https://confluence.atlassian.com/pages/viewpage.action?pageId=151519275

However it is necessary for you to use developer/evaluation license for your staging environment.

If the XML restoration was not completed successfully, than there might some issue on your upgrade process. However, please note that XML backup/restore method is not a recommended method to upgrade your production instance as it is meant for testing purposes only and has been reported to be unreliable for huge instance (may lead to data lost).

Please refer to the following method and see if it is successful for you.

Hope it helps.

Cheers,
Septa Cahyadiputra

Thanks for the answer :) However, I should have told that I've upgraded from 4.1 to 4.3.3 using the internal db. This worked fine, no errors. Then I created the temporary home, moved the attachments and started the Web-Setup. This time I used an evaluation license, but I get the same error.

I can see, from the CPU load, that indexing is running. After CPU load dropped to 0, I restarted Confluence, and it seemed like it worked. Nothing broken til yet, except for one thing: For some reason it uses old versions of the profile images, not the current ones. The whole content otherwise is up to date. This does only happen after switching the database, the upgrade from 4.1 to 4.3.3 itself didn't touch the profile images. I guess this is the XML which backs up the wrong version of the profile images? Is this a known issue?

Opened a ticket yesterday, was told I could ignore the error :)

Thank you!

This widget could not be displayed.

Hi,

You could request for developer license for testing purpose. More on the license, you could just upgrade using your license as it is not bound to your server id. Please read more on server id in here.

This widget could not be displayed.

Hello There,

To obtain a better assistance with this situation about the profile images I would suggest you to raise a support ticket at our Support.atlassian.com and attach your log files to further investigation, we would need to take a look at this information from your instance to identify what could be caused this behaviour in your Confluence.

Cheers,

LJ.

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Published Tuesday in Confluence

Add-on evaluation with confluence templates

Atlassian market place contains number of Apps/Addons which improves the capability of out of the box Atlassian products. It is good to follow a plugin evaluation process before install add-ons. So t...

109 views 12 6
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you