Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Nested tables in Confluence

Hi all,

I used to be able to create a table within a table using the button on top in edit mode. Now, it's grayed out when I'm within a table, and when I hover over the icon, I'm told that nested tables are unsupported.

Is this an issue with the new version of Confluence? Is there a way to get around this? The document already contains nested tables and I would like to keep the format uniform, and copying and pasting does not work.

Thanks,
Jinyoung

14 answers

2 accepted

2 votes
Answer accepted

Is there any workaround?

Savdeep,

If you check the bug ticket I posted in my answer, you'll see that some user has come up with a workaround last month. I recommend you reach out to him on that case for more details regarding the workaround. He's attached some images but they appear to not be showing.

Regards,

Shannon

Hi Savdeep,

Place your cursor in the table and select {} Markup from the Insert More Content menu. Ensure Confluence Wiki is selected from the Insert drop-down. Then, type  ||col into the Insert text box. You'll a table column in the Preview pane. Click the Insert button. A one column, one row table will be placed within the table. You can then add columns and rows as you normally would.

I saw this work around in another post and it has worked consistently for me.

Good Luck,

Denise

Like # people like this

Thanks, this works. 

Denise, your solution saved the day for me! Thanks!

Thanks for this solution Denise. Simple and effective.

Brilliant solution Denise. You saved my day and saved me many hours of work re-constructing Confluence pages.

What if I do not want a header on the nested table?

Jaine,

Create the table via Markup as instructed above.  Ensure the cursor is in the header row of your nested table and then toggle the header on/off using the button on the toolbar. See attached screen shot. 

Creating the table via Markup is simply a way to "start" a nested table. Once the nested table exists, you can manage it via the toolbar buttons just as you would a non-nested table.Header toggle.png

Hi @Denise Kramer

1. Do you by any chance found a workaround on the new Editor released about 2-3 weeks ago?

The {} Markup option is no longer available under the insert options..

2. @Camie Thistleton  referred to the table editing options above here (with the red arrow pointing to the toolbar), this toolbar is no longer available either in the new editor, you now have to select each row or column you want to edit, individually - its very frustrating and unnecessarily time consuming, but there is also no option to create a header row in the middle of an existing table, splitting the table out into sections (the exact icon Camie pointed above here). Does anyone have a workaround to this one also?

Like # people like this

@Zandrea Lange Unfortunately, I have not found a work aroun in the new editor. :(

1 vote
Answer accepted

Hi Jinyoung,

I believe you may be using the new Confluence Cloud version, correct? If so, Nested Tables are no longer supported here.

I've created a ticket in our reporting system so that the team can let us know whether or not it will be brought back, but it may be unlikely.

Regards,

Shannon

I can't believe this functionality has been removed without warning! My company is highly dependent on this functionality for documenting requirements.  I tried copy and pasting a previously created row and the paste functionality did not work as expected.  This is a major issue from our point of view.

Added my comment as well. We rely heavily on our program status pages and inside the tables are more important pieces of data that have to be displayed in a table format. Please provide a work around of some kind.

This is a very useful feature for me too, so I would like this feature to be reinstated. 

Thank you.

Like Veena_Linganna likes this
2 votes
Davin Studer Community Leader Dec 27, 2017

Atlassian recently announced that they are removing that ability. Personally, I think it is a terrible decision as they are assuming that they know best how you should write your documentation. The reason they gave was so that your documentation could be more readable.

Hi Davin,

I created a ticket linked in my answer to gather feedback on this issue, so please feel free to vote on it as well and comment with your feedback.

Regards,

Shannon

I have found the simplest solution..

Simply select the "page layout" icon twice. Then the nestled table becomes available again.

Must be a bug on Atlassian's side.

Holy cow! That’s so cool. How did you figure that out? Also, is this for classic pages or the new editor ?? You’re awesome!

Hehe! Thank you! It's a pleasure! I'm glad you can use it :)

I actually wanted to see if there was some kind of "add table" option under page layouts, and then saw the nested table icon become available again.. who knew..hehehe!

I'm currently working on the classic version. Not a big fan of next-gen, it's got to many limitations on things I need to use, even though it is sleek and pretty.

This is really cool! Thanks! :)

haven't been able to get this to work yet. Here's what I did:

  1. Opened confluence page with table
  2. clicked in a cell with intent to embed a table
  3. clicked page layout
  4. clicked page layout again
  5. table function still greyed out as long as my cursor is in an existing cell

 

is it a different sequence of events from those above?

Hi @Anthony Vizza

That is very strange, I just tried it again now, and it still works, however I only need to select table layout once now, instead of twice.

 

are you using the Classic/Cloud version of Confluence? (I am using this one), the new page layout does not support it.

Here is a screenshot of my screen (get the old page layout under the requirements page template).

Snip20210510_2.png

 

This new page layout below does not work:

Snip20210510_4.png

Nested Tables are still an issue - showstopper. Any ETA on this feature?

In addition, when will numbering be visible on a published page with numbered headings?

Disappoited to discover that nested tables are now not working. Convienced nested tables should be reenabled as soon as posible.

Thank You!

Hi Shannon,

Thanks for submitting the ticket. I have added my comments to it. This change will make creating my API documentation on Confluence very difficult.

Everyone,

The only thing I have found as a work around is to copy an existing nested table and just change the text. It is a lot of work, but in a pinch it can work.

Thanks,

Denise

<deleted as I missed this answer as nested reply above - sorry> 

Unfortunately it looks like View More... no longer has markup available in the Cloud version. Any other thoughts?

Hi Paul, It is still available in my version. Here is a screenshot to be sure you are looking in the correct place.

markup.png

Sadly I cannot find it anywhere... and wonder if this is one more feature that is being removed to simplify Confluence.

 

Are you running on the Cloud version? This is the new editing surface.

Screen Shot 2019-07-02 at 8.13.42 AM.png

Yes, I am using the cloud version. I hope mine does not change anytime soon. :(

Are you using the new editing experience? That might be the big difference. I am now trying to find a way to go back to the old editor.

Good luck and thanks for the input Denise.

Not sure what your data looks like but have you thought about putting your data in a spreadsheet and using the Office Excel macro to include it on your page?

Unfortunately that defeats the purpose of a collaborative document. Might as well use Sharepoint/Dropbox/etc.

 

I really wish we could just flip back to the old editor until the new one was production-ready.

Unfortunately not able to find nested table feature but simulated it using merge and split cells feature of the table. I know it is a bit tedious but it is the closed I have come to simulate nesting. Hope this will help at least some individuals. 

0 votes

This is just crap.  I can't believe that this has been removed.  For those of us out here that are trying to get our companies to use this tool, Atlassian with their "Here today, gone tomorrow" attitude really bites.  

 

All of us that do engineering know there are hard challenges to overcome.  The excuse that less that 1% of the users use nested tables is complete and utter nonsense.  Less than 1% use it because you've DISABLED IT!  We can't use it.

 

And the MS Excel importer is no real gem to replace this.

I really like the Atlassian products.  But you guys make it really hard for those of us that have to explain to our teams that "well, it just doesn't support it, sorry" 

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Confluence

🥓🙅🏻‍♀️ Meet-less May Badge!

Hello Confluence Community!  What if i told you that you could have a healthier life and be 100% meet-less? This month, we're promoting a healthy, balanced work diet with Confluence. (Read m...

514 views 3 23
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you