Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal


  • Give kudos
  • Received
  • Given


  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

My server is showing a blank box where a login prompt should be when I view it's URL

OK, so I had a Confluence v6.12.1 server, which I have upgraded to v7.2.1

HOWEVER, when I go to the default login screen, I get a white box with nothing in it (no user-name field) so I can't log in.

My app logs show{

2020-01-26 22:53:21,688 ERROR [http-nio-8090-exec-9] [ContainerBase.[Standalone].[localhost].[/]] log Unhandled exception occurred whilst decorating page
-- referer: | url: /plugins/servlet/saml/getajaxconfig | traceId: 7038d64a5528134b | userName: anonymous



Which tells me absolutely nothing I know how to action.

Both the installation and the home directory are owned by the user used to operate the server.
I have attempted to resolve this since mid way through November, getting the same results, so I NEED A solution now, as this is NOT the expected 'by-design' operation of the server.

I need this resolved a month ago, so help in resolution is well appreciated!

3 answers

1 accepted

Looks like you had a SAML app installed.

The "/plugins/servlet/saml/getajaxconfig" URL in the log line reveals that the app is trying to get some config via AJAX and fails with a NullPointerException. It's possible that the version you had in your installation before update is not compatible with 7.2.1 i.e. you should have disabled or updated it before the update of the base app.

I can't tell what SAML SSO app is this, but it's not EasySSO (ours). If you don't know which one it was I can only suggest to look into my.atlassian portal and see what licenses you had.

You may need to start the application with all plugins disabled to login and update or uninstall the app temporarily. See How to disable plugins in Confluence in 6.1+ using Java system properties

Thank-you very much Ed, I really appreciate your response.

I was able to start my server with the steps provided in your last link, by modifying the file as below;

1] Comment the line below to disable default options


2] Add the line below to disable all addons, noting that the addons can be re-enabled once the server is operating.
CATALINA_OPTS="-Datlassian.plugins.startup.options='--disable-all-addons' ${CATALINA_OPTS}"

This IS NOT an ideal resolution, but it allows me to get my server back into production for the week, so I am still seeking a permanent solution.

So, the only app I haven't enabled in our production server is the '

SAML 2.0 Single Sign-On for Confluence

' at your specification, though I would like to know how I can identify the associated jar file on my server so that I can dispose of the addon entirely;

Is there a way to determine the source server files from the confluence server?

Confluence stores the plugin binaries in the database. As such you need to click "uninstall" in the UPM UI instead to remove the plugin.

Before you do that, check who is the vendor for the plugin as displayed in the UPM or if it displays a Marketplace link - open that up. See if they had an update for Confluence 7.x compatibility. For me, being an SSO vendor, just "disposing" of SSO functionality in production seems a bit drastic.

Please note: the name as it is displayed in UPM seems to be an old name for the plugin. I think it's this one but I am not sure: SAML Single Sign-On for Confluence. You will see that they did have a release to make it compatible with Confluence 7.x

The catch there, is that I can't review my addons;

My server throws a page not found when I attempt to visit the 'Manage Apps' page;


Page Not Found

We can't find that page. This could be because:

  • The page doesn't exist.
  • The page exists, but you don't have view permission for that space.

Site Search


Go to

  • Site Homepage 
  • Your Dashboard


I am feeling like you've reached the level of "broken" where you need to raise a ticket with official Atlassian support:

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted in Confluence Cloud

Please tell us how you use Confluence space settings

Hi there, a few of us at Atlassian would love to learn about how you use "space settings" functionality in Confluence. A facelift to the space settings is long overdue and we want to start with impro...

309 views 11 8
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you