Mobile Confluence 5.7.1: IllegalStateException: Request-local WebResourceAssembler has already been initialised

Hello,

I have a staging environment to test and upgrade to Confluence 5.7.1. From desktop machines, this setup works OK, but when going to the front page of the Confluence site from an iPad (both Safari & Google Chrome), I get a System Error. See screenshot:

IMG_0047.jpg

Is this a bug, or should I configure something to prevent this?

The only reference to this IllegalStateException comes from the source:

https://bitbucket.org/atlassian/atlassian-plugins-webresource/pull-request/90/plugweb-181-pagebuilderservice-can-be/diff

@Matt Quail, @Paul Curren and @Richard Atkins, you discussed this diff. Do you have any idea what might be wrong here?

Ringo

6 answers

This widget could not be displayed.

@Matt Quail,

I first started with disabling all add-ons. I then looped over all the add-ons and enabled them one-by-one. For every test, I made sure that all other add-ons were disabled. This way, I was able to narrow it down to the Adaptavist Selectacular add-on, which is bundled with their ThemeBuilder. I have reported this to Adaptavist for further investigation.

Ringo

This widget could not be displayed.
Matt Quail Atlassian Team Apr 22, 2015

@Ringo De Smet Can you paste in the the full stacktrace please?

This widget could not be displayed.

@Matt Quail, sorry I forgot it. Here it is:

https://bitbucket.org/snippets/idalko/7nA5

This widget could not be displayed.
Matt Quail Atlassian Team Apr 23, 2015

So DashboadServlet's doGet() is calling pageBuilderService.seed(). There must be some code or filter before doGet() that is calling seed() or assembler(). You might need to track down where it is, maybe set a breakpoint. Some bit of code somewhere is probably calling assembler() in order to call say resources() (e.g. some filter is trying to add a web resource to every request).

You can try and play a game of one-upmanship and write your own filter on /plugin/servlet/mobile where you can put your call to .seed().

This widget could not be displayed.

Hi Ringo,

We experience the same issue. Confluence is working fine, however when accessing links via andoird / iPad we get same error. Adaptavist Selectacular add-on seems related, we'll need some more investigation.

Please keep us posted...

 

@RoBo, I reported this and at Adaptavist this seems te blogged as PRODSUP-608. Please report this too, referring to this case. Currently, they just reported to me that ThemeBuilder is not supported on mobile site. I have the impression that they don't understand that by just installing their add-ons, the mobile site crashes.

Thanks Ringo; I've informed adaptavist (by email) about just having the add-on enabled leading to crash on Android and iPad.

This widget could not be displayed.

Yea - Having the same problem.  Do I turn off the Plugin to allow Mobile to work - Or not have Mobile available to my users?

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Monday in Confluence

Why start from scratch? Introducing four new templates for Confluence Cloud

Hi my Community friends!  For those who don't know me, I'm a product marketer on the Confluence Cloud team - nice to meet you! For those of you who do, you know that I've been all up in your Co...

484 views 6 6
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you