MindTouch export using UWC

I am having an issue exporting the data from our current MindTouch environment and have tried multiple settings, but always receiving the following error:

2013-10-17 18:32:06,034 INFO [Thread-10] - Exporting Mindtouch...

2013-10-17 18:32:06,036 INFO [Thread-10] - Getting page tree.

2013-10-17 18:32:06,076 INFO [Thread-10] - basic authentication scheme selected

2013-10-17 18:32:06,076 INFO [Thread-10] - No credentials available for BASIC 'DekiWiki'@10.40.106.40:80

2013-10-17 18:32:06,076 ERROR [Thread-10] - Problem encountered when making rest call: 401: HTTP/1.1 401 Unauthorized

2013-10-17 18:32:06,076 ERROR [Thread-10] - Problem occured when making rest request to: http://10.40.106.40/@api/deki/pages/?authenticate=true

2013-10-17 18:32:06,077 ERROR [Thread-10] -

Config file is set to:

# Exporter class - class that controls the export. Don't change this.

exporter.class=com.atlassian.uwc.exporters.MindtouchExporter

###### SET THESE ######

## Base Url of your Mindtouch

## could be: 192.168.1.100, http://localhost, https://someplace.com, etc

url.base=http://10.40.106.40

## Port used by your Mindtouch. Default is 80.

url.port=80

## Login Credentials for your Mindtouch. Should be an admin.

user=convert

pass=convert

## Output Dir - where the exported files are put

output.dir=c:\MindTouchExportUWC

###### OPTIONAL ######

## user agent for the Xml Parser. Default is Universal Wiki Converter

user-agent=Universal Wiki Converter

## buffer size in bytes for downloading attachments. Default is 1024

att.buffer=1024

## connection timeout in ms. Default is 10000

timeout=10000

## if true, ignore page with name MindTouch. Default is true

ignore.mindtouch=false

• When browsing the the @api link in the log I am presented with a login prompt and the convert/convert username takes me to the XML page correctly.

• In IIS I have tried

  • Adding Basic Authentication to the IIS role
  • Removing all Authentications other than Basic

• Have created a local username in windows on the server with the same credentials

• Have tried a local user with admin as well as a domain account with admin

• User in Mindtouch has admin in the MindTouch application

• Have removed all authentication methods of MindTouch other than the local normal authentication

• Have tried to just import the MindTouch export of the Wiki, which when imported created a huge mess in Confluence so this is not a workaround

Currently in an evalutation of Confluence and this feature of pulling the MindTouch information over is critical to being able to use Confluence.

Any suggestions on how to get this working would be greatly appreciated. Running Server 2008 R2 with IIS7

Thanks,

Sean

2 answers

1 accepted

This widget could not be displayed.

Redownload the app and never put anything into the attachments entry and it works. Just clearing it out did not.

This widget could not be displayed.

Guess its as suspected and the common issue of Basic Auth is not solved. On to the next product evaluation.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Monday in Confluence

Why start from scratch? Introducing four new templates for Confluence Cloud

Hi my Community friends!  For those who don't know me, I'm a product marketer on the Confluence Cloud team - nice to meet you! For those of you who do, you know that I've been all up in your Co...

484 views 6 6
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you