Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Mailto Link opening Outlook and New Chrome Tab

Hello,

When I click on an email link in Confluence, Outlook opens as normal but so does a new Chrome tab with the link in the address bar. We utilize email addresses in our knowledge base so we will click email links all day. Everything still works but closing out the tabs gets old. 

 

I checked the link and the address is displayed correctly. mailto:me@mywork.com

 

Confluence Version: 6.15.2

Chrome Version: 76.0.3809.100

When the issue started? Sometime during the last few days

 

What have I tried?

- A different space and a different email address

- Turned Off "Open External link in a new tab" 

- Ensured that my Windows Mail App default was set to Outlook

- Turned off "allow sites to ask to become default handlers for protocols in Chrome"

- Test link on Internet Explorer and the issue does not happen

- Tested mailto: link in SharePoint in Chrome and the issue does not happen

- Tested mailto: link in JIRA in Chrome and the issue does not happen

 

It appears to only be Confluence in Chrome having this issues.

 

Any advice or test you could recommend? 

1 answer

0 votes

Hi James,

Thank you for reporting this issue. It's a very interesting one.

I'm testing this currently with Confluence 6.15.4 on Google Chrome version 76.0.3809.100, and when I click on a mailto link in Confluence, it only opens in my default mail application.

The only thing I can think of is maybe that you already had Chrome set to be a default handler. See How To Set or Remove Gmail as Your Default Email Link Handler:

use gmail as your default email link handler

It could be that you received this notification in the past and accepted it by accent, and now it has Google already listed as a handler. In this case, the change you made wouldn't have any effect because it's already been added.

You'll want to check again in chrome://settings/handlers and make sure Gmail isn't listed as a handler. If you still have trouble you can try to reset Chrome and reject the next time it asks, for disable all sites from asking as you did before.

Regards,

Shannon

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

What do you think is the most *delightful* Confluence feature? Comment for a prize!

- Create your own custom emoji 🔥 - "Shake for Feedback" on mobile 📱 - An endless supply of GIFs via GIPHY 🤩 Is there anything quite as nice as a pleasant surprise? Comment below with what...

463 views 24 9
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you