We moved Confluence to another domain and now we can't login in to using LDAP Directory in the Jira. 

Jira works correctly. Both applications installed on same server, on the different ports.

I found this string in the Confluence logs.

2017-08-17 11:46:32,574 ERROR [http-nio-8090-exec-9] [crowd.manager.application.ApplicationServiceGeneric] authenticateUser Directory 'Remote JIRA Directory' is not functional during authentication of 'jiraadmin'. Skipped.

2 answers

This widget could not be displayed.

That is saying that it can't connect to, or is being refused access to, your LDAP server.

There's not a lot more we can tell you than "work out why it can't talk to LDAP"

Which additional information you need, to solve this problem?

I'd look at the LDAP server logs next to see why it refused to let Confluence in.

Although, do you have admin access via a non-LDAP account?  If so, then try going to the directory list and click "test" in the directory that is failing - sometimes the returned error can tell you more without having to dig into logs.

This widget could not be displayed.

I solved network problem, but now another error appers: "Sorry, an error occurred trying to log you in. Please try again."

There is a string in the logs: Caused by: org.apache.http.conn.ConnectTimeoutException: Connect to helpdesk.bms.plus:8080 [helpdesk.bms.plus/77.75.1.139] failed: connect timed out

But helpdesk.bms.plus:8080 is old jira url. How I can change it to new? Maybe through MS SQL?

It shouldn't be trying to connect to anything to log you in.  I'd expect that to be just a problem with config, something to fix after you get back in.

What errors are you getting when you try to login in?  Try running a terminal with a tail -f atlassian-confluence.log ticking over while you do the login in a browser.

What do you mean?

cmd.exe -f atlassian-confluence.log ticking does not works

Can you give me step-by-step instruction?

Ah, sorry, you're on Windows, constrained by its poor tool set.

tail -f is a *nix command which says "list the last few lines in a file on-screen, and display new ones as they get written to it".  I don't know if there is an equivalent on Windows.  It's not critical, it's just useful to see "this click caused those 20 lines to appear in the log".

Can you open up the log as usual, check exactly what the last line is, including a note of the time.  Then try to log in, then go straight back to the log and look at all the lines that were written after the line you noted.

I don't kbow what's happend, but I just tried to log in and it's works. May be something updated at night.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted yesterday in Confluence

Why start from scratch? Introducing four new templates for Confluence Cloud

Hi my Community friends!  For those who don't know me, I'm a product marketer on the Confluence Cloud team - nice to meet you! For those of you who do, you know that I've been all up in your Co...

134 views 1 4
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you