It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Loading Confluence Macro Browser times out

Hi everyone,

recently I'm experiencing the same behaviour as described in this article: https://confluence.atlassian.com/confkb/unable-to-load-the-confluence-macro-browser-due-to-timeout-exception-834006502.html

I'm running Confluence Server 6.15.10 with the Refined Structure Addon.

Difference: I double checked my dxternal gadgets and there are no gadgets configured at all and it occurs occasionally. It seems to be more typical after a system reboot but not constant.

To verify this I used the postman as described in the article to request the given url http://<confluence-url>/plugins/macrobrowser/browse-macros.action?detailed=false and found that the initial request took 2.5 minutes. Subsequent requests took only 50 ms. This coincides with my experience when using the Confluence front end when trying to add a macro in page edit mode, e. g. using the "{" shortcut. The initial call times out, subsequent tries work as expected.

I had a closer look in the response within postman but found nothing suspicious except for the link location to the confluence news gadget pointing to the external ressource "https://www.atlassian.com/gadgets/images/thumb/confluence-news.png" which is being redirected to a website.

I'm running other instances which don't have that effect. So far its only on one of our test instances.

Any ideas?

 

1 answer

0 votes

Hello Manuel,

Happy to help you solve this issue! 

Can you confirm if you disable all add-ons and run Confluence in Safe Mode does the issue persist? 

Checking the Confluence Server logs per the article, can you show me the stack trace you receive when replicating the error?

Lastly, a few more questions about the scope:

  1. Does this happen in other browsers?
  2. Are all users affected?
  3. Are you accessing Confluence through any proxies?
  4. Was Confluence ever linked to a Jira server?
  5. If you try accessing Confluence from its IP address, does the macro browser load then?

Thank you for your help!

Regards,

Shannon

Hi Shannon,

thanks for your help. In my experience, it only happens after a confluence restart. Today I was able to take some screenshots and get the logs. Using the front end I got the following result:

Left: initial - times out after maybe 60 seconds

Right: Time out - on second retry opened up the macro browser as expected.

macro browser.png

 

The log is as follows:

2020-01-21 07:37:19,636 WARN [https-jsse-nio2-8443-exec-25] [atlassian.upm.pac.PacClientImpl] getUpdates The request to check for add-on updates may take longer than expected because 210 user-installed add-ons are installed. This may impact the performance of loading the Manage Add-ons page.
-- referer: https://<url>/plugins/servlet/upm | url: /rest/plugins/1.0/installed-marketplace | traceId: af814563c6a390b8 | userName: admin
2020-01-21 07:39:14,172 WARN [https-jsse-nio2-8443-exec-15] [confluence.util.profiling.DefaultActivityMonitor] close Exceeded the threshold of 60000 ms: ActivitySnapshot{startTime=1579588609122, threadId=29, threadName='https-jsse-nio2-8443-exec-15', userId='<unknown>', type='web-request', summary='/plugins/macrobrowser/browse-macros.action?detailed=false&macroMetadataClientCacheKey=1579570485120'}
-- referer: https://<url>/display/MI1 | url: /plugins/macrobrowser/browse-macros.action | traceId: 1858c155226ef4fb | userName: anonymous
2020-01-21 07:39:17,460 WARN [https-jsse-nio2-8443-exec-17] [confluence.util.profiling.DefaultActivityMonitor] close Exceeded the threshold of 60000 ms: ActivitySnapshot{startTime=1579588660928, threadId=31, threadName='https-jsse-nio2-8443-exec-17', userId='admin', type='web-request', summary='/plugins/macrobrowser/browse-macros.action?detailed=false&macroMetadataClientCacheKey=1579570485120'}
-- referer: https://<url>/display/MI1 | url: /plugins/macrobrowser/browse-macros.action | traceId: bd5d18f28e7811ef | userName: admin
2020-01-21 07:39:19,306 WARN [https-jsse-nio2-8443-exec-3] [confluence.util.profiling.DefaultActivityMonitor] close Exceeded the threshold of 60000 ms: ActivitySnapshot{startTime=1579588662791, threadId=17, threadName='https-jsse-nio2-8443-exec-3', userId='admin', type='web-request', summary='/plugins/macrobrowser/browse-macros.action?detailed=false&macroMetadataClientCacheKey=1579570485120'}
-- referer: https://<url>/pages/editpage.action?pageId=6717622 | url: /plugins/macrobrowser/browse-macros.action | traceId: ff2fb2dd6f037aac | userName: admin

Except for some minor stale checks confluence stated "ready to serve" just before that stacktrace, meaning I was the first user after the restart to log in. Makes me wonder if some sort of Macro browser cache/index hasn't been initiated.

Regarding your questions:

  • No proxies.
  • No JIRA connected

Towards other users and browsers I need further testing. Not every restart is affected which makes it hard to track down...

Thanks.

Hi Manuel,

Thank you for the information and the logs. Is the restart that triggers it a normal restart, or was it due to some issue, such as a memory outage? 

Did you have a chance to disable all add-ons and see if the issue persists then? 

Regarding your logs, the messages in the stack trace you sent me shows us that there is a timeout, which we already know.  We'll need a deeper look at that stack trace. Can you try to see if there are any lines that start with ERROR followed by caused by? That should give us a better idea of what's causing the timeout.

It will also help to see what's in your Developer Tools console when triggering the error.

Thank you for your help!

Regards,

Shannon

Hi Shannon,

I have the same problem, it happens after restart (because confluence service is restarted  (restart or stop/start) or system restart. It happens also after enabling some plugin.

I tried accessing:

http://<Confluence URL>/plugins/macrobrowser/browse-macros.action?detailed=false

And it works some minutes later I tried first access (to URL or loading macro browser) 

Problem es exactly described here, but I haven't any gadget or application link

Developers console log:

Anotación 2020-01-26 131304.jpgI also have a lot of errors "Uncaught TypeError: m.test is not a function", this error is raised every time I move the mouse or do any action.

Jaime,

Thank you for for providing those details.

Can you try clearing the plugin cache manually and see if that solves the issue for your site?

  1. Shutdown Confluence
  2. Ensure the user running Confluence has full read/write privileges to the confluence-home directory.
  3. Remove the following directories
     This will remove the plugin cache files only and will not permanently remove any plugins. These directories will be recreated during the next Confluence startup. However, some third-party plugins may store metadata in these directories, so we recommend creating a temporary backup of the directories.
    • <confluence-home>/bundled-plugins
    • <confluence-home>/plugins-cache
    • <confluence-home>/plugins-osgi-cache
    • <confluence-home>/plugins-temp
    • <confluence-home>/bundled-plugins_language
  4. Start Confluence

Let me know how that goes.

Regards,
Shannon

Hi Shannon,

I did it, but the problem still remains.

Hi Jaime,

Thank you for testing, and my sincere apologies for the long delay.

In this case I would definitely recommend attempting the safe mode, in that case. Make sure that ALL of your add-ons are disabled.

If you say it happens when enabling some plugins too, then we know that it's an active plugin which is causing the issue. Follow all the steps at the bottom of that page, and once they're all deactivated, you can start to enable them one at a time until you discover the problematic add-on.

Let me know how that goes.

Shannon

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

How is your team having fun and bonding, remotely, utilizing Confluence?

Thanks everyone for answering last week’s question. The winner of the random drawing from those who commented is: @LarryBrock I’ll contact you separately with your prize details. This wee...

283 views 9 7
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you