Linking to Windows file server share UNC path not working

My Confluence server is for internal use only, so all my users are local and have privlages to the shared files. I am doing the following:

[\\server\share\path]

Which is supposed to work I think, but it is being interpreted by browsers (have tried FF and IE) as

File://server/share/path

And clicking it does nothing. Am I missing a plugin maybe?

7 answers

1 accepted

This widget could not be displayed.

The file:// URI is blocked by default in IE9, Firefox, and Chrome. I can't figure out what security setting it is in IE that needs to be toggled, but the easiest solution is to add the confluence URL to a more trusted zone, like Intranet. Also, if your Confluence site is internal, you can connect to it with just a hostname instead of a FQDN. The default settings in IE will assume any site with just a hostname is inside the Intranet zone.

This widget could not be displayed.

On a lark I tried typing in the file: URL into a browser bar directly and it opened, so it appears to be confluence related.

This widget could not be displayed.

Per http://blogs.msdn.com/b/ie/archive/2006/12/06/file-uris-in-windows.aspx

"The number of slashes following the ‘file:’ is dictated by the same rules as other wellknown schemes like http and ftp. The text following two slashes is the hostname. In the case of the UNC Windows file path, the hostname appears immediately following the ‘//’. In the case of a local Windows file path, there is no hostname, and thus another slash and the path immediately follow."

It's IE 9 that I'm testing with though. Looks like there's a security toggle in Internet Options I need to find, since dropping the default from Medium to Medium-Low fixed the problem. I'll post the setting when I figure out which one it is.

This widget could not be displayed.
  1. There's an security option in the "Medium-High" setting for IE that needs to be enabled called "Allow websites to oppen windows without address or status bars." Once enabled the UNC link in the form[\\server\share\path] works as expected in IE.
  2. Firefox requires preference editting via instructions at http://kb.mozillazine.org/Links_to_local_pages_don't_work
This widget could not be displayed.

This used to work for us in Confluence 3.5, but once we upgraded to 4.0, nothing works for UNC paths. However, OS X users are still happy because "smb://servername.domain.com/share/subdir/file.name" works dandy.

Since this capability is really important for our companywide tool library, we're completely hosed when trying to rollout updates for tools.

What's the workaround, Atlassian?

This widget could not be displayed.

When is this functionality be available again? This tremendously affects the usability of the tool in Enterprise environment, our users simply don't want to use it, because such a basic functionality is broken.

This is caused by a change in how browsers work in Windows, not a failure of Confluence. That is the main problem.

Steven Behnke Community Champion Aug 04, 2014

You are totally correct Bill. Browser and OS companies decided that being able to open files that way wasn't secure anymore, so they blocked the connection.

Mozilla suggests techniques for linking to local files [1]. [1] says they don't work in Firefox 29 but are fixed in Firefox 30. I have Firefox 31, and I can't get it to work. There is even an extension that promises to work around this [2]. I can't get that to work, either. It doesn't even work in the address bar. This is Firefox behavior. Atlassian can't work around it.

[1] http://kb.mozillazine.org/Links_to_local_pages_don't_work

[2] http://locallink.mozdev.org/

This widget could not be displayed.

1) Ping the IP.

2) Use "Run" and try \\localhost, if this doesn't work then refer below

https://superuser.com/questions/323598/windows-7-unable-to-browse-to-network-shares-in-explorer-but-map-network-driv/917645#917645

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Monday in Confluence

Why start from scratch? Introducing four new templates for Confluence Cloud

Hi my Community friends!  For those who don't know me, I'm a product marketer on the Confluence Cloud team - nice to meet you! For those of you who do, you know that I've been all up in your Co...

375 views 3 6
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you