Link to heading doesn´t work anymore?

Some weeks ago, if I clicked on a title of the content table, I used to get a complete url with the head title inclueded, now I just get the ulr of the page. Did it change?

2 answers

This widget could not be displayed.

Hi Juliana,

Can you clarify for us which features you're referring to? Are you clicking a link in a Table of Contents macro, or do you have Anchors set up? 

If you have any screenshots of the problem you're able to share with us, please do.

Kind Regards,
Shannon

This widget could not be displayed.

Hi, Shannon.

 

Yes, clicking a link of a Table of Contents macro before used to give me an url as if I had an anchor. Did it change?

 

Thanks! 

Hi Juliana,

I'm testing this on my copy of Confluence which is the current version. I've created anchors on all the headings, and then inserted a Table of Contents macro at the top.

When I click on one of the links, it changes the URL to match the anchor that is already on the page. Is this the behavior you're referring to? It appears to still be accurate.

Screen Shot 2017-09-07 at 3.02.38 PM.png

Could you let me know what version of Confluence you were running before and after it occurred? Did you make any changes to the page?

Kind Regards,
Shannon

Exactly, Shannon.

 

For me, it doesn´t worl. As you can see in the pic bellow, I´ve just clicked on "Status", from Table of Contents, I was redirected to the header, but the url didn´t change: link_head.png

T

Hi Juliana,

Thank you for that. I see you are actually on Cloud and using the New Look, so this change is due to that and is expected.

The example I was showing you is how it works in Confluence Server which is a different platform now.

Can you let me know why you might require the URL to change when clicking on the anchor? Perhaps I can help with a workaround for that.

Kind Regards,
Shannon

Hi, Shannon.

That´s the way I used to copy the url to create links (from address bar).

For new links, I can copy the url using "copy link" option of mouse right-click. It works.

The problem is that "old links", copied from the url address bar doesn´t work anymore. Any idea?

Thanks again.

Juliana

I do know the formatting has changed with the New Look, so this is likely why the old links aren't working.

Are you able to compare the old with the new and determine how the old ones should be reformatted?

Kind Regards,
Shannon

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Monday in Confluence

Why start from scratch? Introducing four new templates for Confluence Cloud

Hi my Community friends!  For those who don't know me, I'm a product marketer on the Confluence Cloud team - nice to meet you! For those of you who do, you know that I've been all up in your Co...

293 views 2 4
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you