Link to a file on a secured drive

When I put a link to a file on one of our secured share drives in an email, a user can click on it and either the file associated with the link downloads or the user receives an error if they don't have permission to the file.

When I put the same link into a Confluence page as a web link, it appears as a clickable link, but when any user clicks on it, nothing is done. We've tried to force open in a new tab to see what might be going on. But, literally, nothing happens.

The link looks likes this:

\\shareddrivename\encrypteddata\customername\SharedProjects\product\productifle.xlsb

When you hover over the link, in the footer area, confluence appears to be resolving it as:

file:///encrypteddata\customername\SharedProjects\product\productifle.xlsb

Why is the part of the link, \\shareddrivename\, being replaced by file:/// ?

How do I insert a link into Confluence that will properly resolve to the file that we are trying to provide to the user?

3 answers

1 accepted

0 vote
Davin Studer Community Champion May 19, 2014

Also, the only browser to support the file protocol out of the box is Internet Explorer. Firefox and Chrome both have extension that can enable the file protocol, but it is disabled by default for securty reasons.

That was helpful. I'm using Chrome and Firefox (mac person). I installed the extension for Chrome and am able to use the file:\\ protocol. Now I just have to figure out why the file cannot be found :-)

Davin Studer Community Champion May 19, 2014

You also need to flip all of the "\" in the unc path to "/".

Davin Studer Community Champion May 19, 2014

What we put into the web url field is file://///server/subfolder/file.txt. The file:/// is the protocol. The next // begins the unc path. So, yes you need five "/".

That's very helpful. Thank you so much!

0 vote

It's the browser - Confluence is faithfully presenting the "link" string given to the browser, but the browser doesn't understand that it's a file share because \\shareddrivename is LOCAL to the client and the browser and server haven't been told that. Your browser is guessing that what Conflluence is handing to it is a file as a last resort.

Think of it this way - my house is called "The Old School Room, in town X". Globally, the post office knows my address is <house number><post code>. If you write the first name on an envelope, my post man WILL deliver it (your email client), because he knows the mapped name. But when he's on holiday, his stand-in has no idea that the first name is an alias for their official name.

You need to include the *actual* shared full unc string for Confluence to stand a chance of giving data to the browser that enables the link to work.

Nic, that makes sense. I've put in an IT support request to get that information..but, I do understand. Appreciate the quick response and explanation!

Nic, I replaced the <share> with the UNC path and I could ping it successfully. However, do you know what kind of link I need to be inserting because when I put the link in with the UNC, it resolves it so https://\\.... If I use Advanced, it doesn't like it because it is not in the appropriate wiki markup (and that seems more for links to Atlassian content).

Any advice on how to actually insert the link to navigate to this location?

The file call format "[file:///c:/path/to/your project folder/file/example.pdf]" works fine for us for local HDD access. Note the 3 forward slashes after "File:", and that we can accommodate spaces in the path and file name.

In addition, as all our offices have the same drive mapping with replicated files and folders for our project files on our different servers, we can also use:

"[file:///x:/path/to/your project folder/file/example.pdf]",

and this will open the relevant PDF stored on our drive mapped fileshares.

Note that for Chrome to process the File call correctly, you need to do two things:

  1. start Chrome like this:

"C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" "--enable-extensions --allow-file-access-from-files"

     2. Install the LocalFiles add-in by going to the following:

https://chrome.google.com/extensions/detail/jllpkdkcdjndhggodimiphkghogcpida

The issue we have is that the above works fine for file types that the Browser can open internally. But it won't work for other file types, e.g. *.docx, or *.xlsm. In these cases the Browser finds the file OK but it just opens a dialogue to "Save As", which is not appropriate.

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Kesha Thillainayagam
Posted Apr 13, 2018 in Confluence

We want to hear how your non-technical teams are using Confluence!

Hi Community! Kesha (kay-sha) from the Confluence marketing team here! Can you share stories with us on how your non-technical (think Marketing, Sales, HR, legal, etc.) teams are using Confluen...

2,856 views 27 11
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you