Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

3 answers

1 accepted

1 vote
Answer accepted
Brant Schroeder Community Leader Apr 22, 2021

@Artem Mozgovoi   Welcome to the community.   The link you are adding has characters that are not allowed so Confluence removes them and provides the # link.  I believe this is to prevent cross site scripting.

Can you advice some workaround maybe for this case? Is it possible to have link with special characters?

1 vote
Diego Atlassian Team Apr 22, 2021

Hello there @Artem Mozgovoi!

Interesting behavior! I tried to place the link you provided in my site and it works as expected. I used it "raw", with no display text and also with display text:

Edit mode

Screen Shot 2021-04-22 at 12.32.10.png

View mode

Screen Shot 2021-04-22 at 12.32.18.png

 

With this in mind, I would like to ask you a few questions:

  1. How do you insert the link?
  2. Does this happen with other links as well?
  3. Would it be possible for you to take screenshots of the result in both edit and view modes of your page?

Let us hear from you!

Hey Diego, thank you for answering. Have you tried to click on that new link? It also displayed as correct link for me but it navigates on /# route as confluence replaced it on publish

1 vote
Brant Schroeder Community Leader Apr 22, 2021

@Diego I also tested the link and it was fine until I published as well.  Once published the link reverts to # which is the same behavior I have seen if you try to input JavaScript.  I believe that your application is trying to prevent cross site scripting and this link does not work because of how it is formed.

is there some known workarounds for that?

Brant Schroeder Community Leader Apr 23, 2021

@Artem Mozgovoi None that I know of or Atlassian would have a security vulnerability.  I guess you could create a bitly link and use that instead.

Like Artem Mozgovoi likes this

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Confluence

🥓🙅🏻‍♀️ Meet-less May Badge!

Hello Confluence Community!  What if i told you that you could have a healthier life and be 100% meet-less? This month, we're promoting a healthy, balanced work diet with Confluence. (Read m...

359 views 3 18
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you