It's not practical for us to upgrade our site at this time, but a patch has not been produced for this issue. What are our options to mitigate the problem?
We only release patches for Critical security issues, but this one has only been designated as High risk so there isn't a patch released with this security advisory. I also see that there doesn't appear to be any suggestions for mitigate this issue, but the XSS issues affect cookies so I believe that this vulnerability goes to the core of the application and therefore the only mitigation is to upgrade. Of course if your Confluence isn't exposed to the internet then you are at less risk of malicious attack, but the XSS issue would still remain a threat to people who have access to the network. Although I think the best way of mitigating the threat from XSS attacks is to understand how they work, as this is always the easiest to prevent attacks: http://www.cgisecurity.com/articles/xss-faq.shtml
All the best,
Yes, it is vulnerable, as explained in the security advisory, this vulnerability affects all versions of Confluence earlier than 4.1.8 and it has been fixed in Confluence 4.1.9 and later.
Regarding the 3.5.x, the latest version would be the 3.5.17 version and if you're planning to upgrade your instance we would suggest you to upgrade to a more recent version (4.3.x).
Hope this helps.
Connect with like-minded Atlassian users at free events near you!Find a group
Connect with like-minded Atlassian users at free events near you!
Unfortunately there are no AUG chapters near you at the moment.Start an AUG