Jira User Directory linked to Confluence not working

Hi,

I just installed my Confluence (6.5.1). Now I want to connect the User direcory from my Jira (7.5.0) instance to Confluence.

I created the application to Jira User server as mentioned in documentation.

When I want to connect Confluence to Jira, I only get an error while testing the connection:

Connection test failed. Response from the server:

Using the admin Username:

com.atlassian.crowd.exception.InvalidAuthenticationException: Application failed to authenticate

Using the application name I configured in Jira:

Connection test failed. Response from the server:
com.atlassian.crowd.exception.ApplicationPermissionException: Forbidden (403) Encountered a "403 - Forbidden" error while loading this page. client.forbidden.exception Go to JIRA home

I have definitivly the correct credentials. 

Jira configuration looks like this:

Application name 
confluence

IP Addresses
10.0.0.0/24
10.0.0.18
127.0.0.1

 

Jira and Confluence are running on the same server. 10.0.0.18 is the IP of the server. Access to Jira is over a reverse proxy.

2 answers

1 accepted

Hi,

I can reach both applications in my browser.

In Jira I can see the Confluence link and vice versa.

Status in both applications is 'connected'.

 

I have 32GB RAM in my server, so I think it should be enougth.
Have not done any explicit memory configuration. It is only a private instance for 5 users.

Sounds good. What is the URL of the Confluence app that is entered in Jira (when you click on edit for the application link)?

http://localhost:8060

The 'Go to remote' link is working

OK, is the localhost link going through reverse proxy or around it?

About the problem, so the apps are reporting connected but you cannot log in to Confluence and you can log in fine to Jira, is that the current issue? Can you post a log snippet from Confluence showing the error?

It's the direct URL without reverse proxy as I have problems with the RP configuration. Just posted another question.

I can login to Confluence using the user created during setup. Jira works without problems.

I want to connect the User repository from Jira to Confluence to manage all users in a single place. 

Using this link in Confluence, I want to setup the connection to sync the users:

http://localhost:8060/plugins/servlet/embedded-crowd/configure/jira/

In the log I can't find any entry with this exception, but in the UI I get an error messagewith the exceptions mentioned in the first post.

Interesting, because atlassian-confluence.log should contain errors of this type. Nevertheless, can you confirm that the steps here are followed:

https://confluence.atlassian.com/doc/connecting-to-crowd-or-jira-for-user-management-229838465.html

If I understand, the Jira side of the configuration is complete. Then in the confluence side you should have the User Directories configured with:

Directory Name Type Order Operations
Remote JIRA Directory Atlassian Crowd

as the first entry on that list. Once you have that, there is a Test link which you can use to validate the connection. Further there is a Synchronise link which should work. Can you let me know if you are getting that far or getting the error along the way. Thanks 

Hi,
found the log entry. Just looked at the wrong folder. Content is at the end of this post.
Step one of the documentation (To connect Confluence to a JIRA application) is completed.
On step two I stucked at testing the link from the Confluence side as you can see in the screenshot.

Screenshot (1).png

Log is here:

https://drive.google.com/open?id=1zUoza-OBCCsGvYDPtsN-KHQiCwUpqAmG

Was not able to insert it within a post. Some signs inside are not accepted.

Hello Stephan,

Thanks for the error, so it is just Confluence failing to authenticate as admin user in Jira. Am still unclear of why this would fail if the admin credentials are correct. Can you upload screenshots of:

1. the Confluence administration page User Directories (http://confluence_server:port/plugins/servlet/embedded-crowd/directories/list)
2. the Confluence administration page Edit Security Configuration (http://confluence_server:port/admin/viewsecurityconfig.action)
3. the Jira administration page Configure Application Links (http://jira_server:port/plugins/servlet/applinks/listApplicationLinks)
4. the popup on previous page when you click edit on Confluence linked app (plugins/servlet/applinks/edit/xyz...)

Hello,

here are the screenshots:

1. the Confluence administration page User Directories (http://confluence_server:port/plugins/servlet/embedded-crowd/directories/list)

Screen Shot 2017-11-28 at 10.39.10.png2. the Confluence administration page Edit Security Configuration (http://confluence_server:port/admin/viewsecurityconfig.action)Screen Shot 2017-11-28 at 10.40.08.png3. the Jira administration page Configure Application Links (http://jira_server:port/plugins/servlet/applinks/listApplicationLinks)Screen Shot 2017-11-28 at 10.40.29.png4. the popup on previous page when you click edit on Confluence linked app (plugins/servlet/applinks/edit/xyz...)Screen Shot 2017-11-28 at 10.41.06.png

Thanks a lot for the screens. Let's try this, I think the problem is a mismatch in the application name string. 

1. Go in Jira to Administration / User Management (.../secure/admin/ConfigureCrowdServer.jspa). Delete the existing Confluence entry (if there is one) and re-create it. Use 'Confluence' as the application name and the admin password to authenticate in Jira. Save the entry and it should appear in the top of the list in "Configure User Applications'

2. Go to Confluence in Administration / User Directories (.../plugins/servlet/embedded-crowd/directories/list). Add a directory and select type 'Atlassian JIRA'. Use the internal URL to jira and the admin password, the application name has to match what you entered in step 1, for me it's just 'Confluence'. Test and save if it validates.

3. Move the Jira directory entry to the top of the list so it is the defult authorization provider. Test and Synchronise links should work correctly. If so, everything should be working correctly.

Let me know if you are able to complete the 3 steps successfully.  

Hi,

thanks. With the internal URL everything worked as expected.

Does that mean using user directories from Jira in Confluence does not work through a reverse proxy?

Fisheye is configured to use the public URL of Jira to use the user directory.

It should work but due to the earlier problems you had, in such situations we recommend working around it:

https://confluence.atlassian.com/kb/how-to-create-an-unproxied-application-link-719095740.html

Same error i am getting. I am not sure what is the application password here.

Could any one will help me here

 

2018-05-16_17h33_05.png

0 votes

Hello Stephan,

If you navigate in Jira to /plugins/servlet/applinks/listApplicationLinks does it report that Confluence is connected? What is the URL of the Confluence app that is entered in Jira? Are you able to reach that URL from your browser?

Let me know these details and hopefully I can get a better idea why the authentication is failing.

Another side question is if you've configured enough memory for both apps and if the server has sufficient RAM to accomodate both applications.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Oct 24, 2018 in Confluence

Atlassian Research opportunity with Confluence templates

Do you use templates with Confluence? Take part in a remote 1-hr workshop. You'll receive USD $100 for your time!   We're looking for people to participate in a   remote 1-hr workshop...

1,096 views 17 14
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you