Jira Isues Macro Stopped Working - Status Code 401

A couple of days ago our JIRA Issues Macro stopped working: instead of the link, we get "JIRA Issues Macro: com.atlassian.sal.api.net.ResponseStatusException: Unexpected response received. Status code: 401".  The only thing that we think may have changed on our side is that the former Confluence admin, who is no longer with the company, was removed from the Active Directory around that time. 

When I go to administer Confluence (General Configuration => Application Links), I am told that I don't have any application links right now.  When I try to enter our URL for JIRA and click "Create new link", though, I am told "An Application Link to this URL... has already been configured."

1 answer

When I edit the page, I can click on "View in JIRA", and the issue displays correctly.

When I click on "Edit", I am told "Login & Approve to retrieve data from...".  When I click on the link, I get HTTP 400 Bad Request. 

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Feb 06, 2019 in Confluence

Try out the new editing experience

Hi team, I’m Avinoam, a product manager on Confluence Cloud, and today I’m really excited to let the Community know that all customers can now try out the new editing experience and see some of the ...

792 views 33 5
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you