Jira Issues Macro not working - content rendering

Background:

We have a Jira On Demand Instance, and an internal instance of Confluence running 3.5.1.

We had been pulling our content from our Jira On Demand Instance into our Confluence instance using the jiraissues macro w/no issues. Unfortunately, the content is no longer being pulled... the macro appears to just sit there with a "Processing, please wait..." indicator

Sample code of jiraissues macro instance (I obfuscated username, password, and specific doman)

{jiraissues:url=https://ourjirainstance.jira.com/sr/jira.issueviews:searchrequest-xml/temp/SearchRequest.xml?jqlQuery=project+%3D+%22CSC+Universal+Binary%22+and+%22Issue+Source%22+%3D+%22User+Acceptance+Test%22+and+%22Reported+Version%22+%3D+%22Version+3.2%22+ORDER+BY+status+ASC%2C+key+DESC&tempMax=1000&os_username=omited&os_password=omited|columns=key;priority;summary;reporter;assignee;reported build;status;created;updated}

Thoughts? This was working fine... someone most have been tweaked in one of the Jira OnDemand updates???

2 answers

You may need to dig into the logs, could be a connection timeout. You can enable DEBUG logging on the plugin specifically if needed, though I suspect there should be something already.

Check the Application Link configuration in Confluence and validate overall connectivity. (You could also try using CTRL+SHIFT+J while editing a doc to test)

If that works try using a filter in JIRA that returns a small result set (a few issues), and see if the result differs.

Also I had an issue specifying fields once, and if I just left it empty the macro worked, so you may give that a shot.

I tried two tests... 1) I constrained the search to pick up a unique jira ticket (based on a defined issuekey) and it continues to spin. 2) I then took the above example, and removed all explicit columns, and again, I continue to see the spinner...

0 vote
David Maye Atlassian Team Nov 18, 2013

It sounds like the JIRA issues aren't able to be pulled into Confluence. I'm not sure what your JIRA/Confluence settings are, but this bug ticket may be related:

https://jira.atlassian.com/browse/CONF-31663

Otherwise, usually a spinning icon means that the macro finds the JIRA issue, but seems to get stuck grabbing the data (for whatever reason). If you're on a self hosted Confluence server, I would suggest either rebooting the server or disabling/re-enabling the JIRA Issues module and see if the issue persists.

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Sarah Goff-Dupont
Published 6 hours ago in Confluence

Think you know shares vs. @mentions in Confluence? Take this collab quiz.

To anyone who doubts that Atlassians are a little too obsessed with collaboration, and tools related thereto, let me describe a recent discussion we had (which took place on our internal Confluence, ...

71 views 2 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you