Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Jira Issue Macro in Confluence: Jira Custom-Fields not displayed

Since the Update to Confluence 7.4.1 and Jira 8.5.5 we had the problem that the Custom-Fields in the 'Jira Issue Macros' are not displayed correctly.

The Custom-Fields are empty. After an Reindexing/ restart of Confluence 80% of the Jira Custom-Fields are displayed. One or 2 days later, the fields are empty again.

Have anyone an idea?


4 answers


Has there been any updates on this issue? There is no option to disable the Jira Macro for the Cloud service. 

+1!! What's going on with Cloud?? Custom fields is the lifeblood of most processes! This has to work!

Like Curt Holley likes this


Same problem here. We do have some projects from the past where the custom fields are synced nicely and a new one where the fields are empty while using the Jira-macro @ a Confluence page!


(Edit: using Jira Work & Confluence - both Cloud)

Hello all,

Have the same problem here, We have created some custom fields and we are not able to see it in Confluence. We are in cloud version. Any ideas how we can solve it?

For us, it kinda just started working after a day or two. Same others have experienced. :shrug:

0 votes
Shannon S
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Jul 07, 2020

Hello Patrick,

Thank you for bringing this to us. I've heard similar reports of this behavior, and we're investigating the issue now in Confluence support.

These issues don't seem to appear straight after an upgrade, but a few days after. 

As a workaround, you can disable the Confluence Jira Macro in System add-ons, and then re-enable it after a few minutes. See Disabling and Enabling apps for information on how to do that. Do let me know if you have any trouble with that.

Once I have a bug ticket to share with you, I will include that here.

Thank you,


Hello Shannon,

I also do have thes issue with the content of custom fields not getting displayed in Confluence. I am looking forward to this problem getting fixed.

My question for your proposed workaround: I cannot disable and re-enable the Confluence Jira Macro because it is a system addon (that ist managed in the "Atlassian Universal Plugin Manager Plugin" right?). The link you provided just explains how to disable user addons and also states:

System apps often can't be disabled, because they're integral to the operation of your application.

So, do you have a method to execute your workaround?

Best regards,


Shannon S
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Aug 04, 2020

Hello Gero,

Thank you for following-up on this.

Regarding disabling and re-enabling the Confluence Jira Macro, this should still be possible. The documentation states that they often cannot be disabled, as some system add-ons are required to keep Confluence running. Others can be disabled, much like the Confluence Jira Macro. Were you having any issues disabling it? If so, you may want to be sure that you are the system administrator.

However, I have good news concerning this case! Since @Patrick Gießler raised this question, there was a bug reported for this which has been resolved:

  • CONFSERVER-60050 Custom Fields are missing in Jira Issue Macro after upgrade to Confluence 7.4.1 and Confluence 7.5.0

A fix for this issue is available to Server and Data Center customers in Confluence 7.4.3. Upgrade now or check out the Release Notes to see what other issues are resolved.

If you're running the Confluence 7.4 Enterprise release, a fix for this issue is now available in Confluence 7.4.3, which you can find in the Download Archives.


If you're not able to upgrade at this time, there are a few workarounds mentioned, including disabling the Confluence Jira Macro or downgrading the plugin itself.

  • Disabling the Confluence Jira Macro from the System Plugins and enabling it after few minutes. (this workaround doesn’t work 100% of times, sometimes it needs to be done multiple times)
  • Restarting Confluence.
  • Downgrade confluence-jira-plugin to 11.0.14 for Confluence 7.4.1
    • Please note that the JAR file is available for download from this bug ticket.

I hope this helps but let me know if you have any trouble.


Hey Shannon,

thanks for the quick response! As of now, we are on 7.4.1 and it is currently working. But if it breaks again I now know to upgrade to 7.4.3, so thank you.

Regarding the de- and reactivation, I am System Admin, but still cannot find a way how to do it. My question in my last post also was: The Jira Confluence Linking Macro is managed in the "Atlassian Universal Plugin Manager Plugin" right? I do have 199 modules in this one and none can be deactivated nor can I find any, that has the name "jira" in it (which I assume, will be part of the module name). So I may just look at the wrong place for the deactivation of system apps, but I do not find any documentation in your wiki where it is explained how to do that. Also not in here: Disabling and Enabling apps.

So how is it done? The answer to this question may also be of interest to anybody who searches for the custom field topic, in order to be able to execute the workaround.




Like # people like this
Shannon S
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Aug 05, 2020

Hello Gero,

Glad to hear that it's working again as of 7.4.1!

As far as the Confluence Jira Macro, it's a standalone system app in UPM (Universal Plugin Manager). You can find it by searching for "jira" in your System Apps:

CleanShot 2020-08-05 at 12.56.08.png

I can also confirm that I'm able to disable and re-enable this macro without any difficulty. You shouldn't have any issues doing this if it should happen again!

Take care,


Like Chris likes this

Ah okay, thank you very much for the tutorial, I found it!

Like Shannon S likes this
Shannon S
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Aug 05, 2020

You're welcome, Gero. I'm glad it helped. :) 

If you need anything else, please do let me know! 

Take care,


Hi Shannon,

I am also experiencing the above issue i.e. custom Jira fields not being displayed in Confluence. I'm on the cloud versions of both of these applications?

I don't seem to have access to disable and re-enable that plugin either and I am a site-admin.

Can you help please?


Like # people like this

Same here--on Jira Cloud custom fields don't work and there's no option to disable the macro


Like # people like this

I am facing the same issue.

Jeff Wheeler
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
Jun 29, 2023

I was facing the same issue... tried a bunch of different things with nothing working. I could not disable the plugin and re-enable it either.


I added a description in the custom field configuration page, then refreshed the Confluence tab in my browser, then searched for the custom field again inside of the display options and it finally worked.

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events