Probably a stupid question, but...

Does Confluence only run on the latest version of Java, and is it stable on 1.6.19?

We use that old version of Java for other, business-critical, programs so need to know if this will run alongside before committing.

Thanks

2 answers

1 accepted

This widget could not be displayed.

Hi Andy,

Which version of Confluence are you using?

Java 6 is supported up to version 5.1 but starting with version 5.2 it will no longer be supported.

As Alex points out you can install a new JVM (Java 7) in a different directory and just update your setenv.sh or setenv.bat (change all mentions of the Java 6 location to the Java 7 location) file in the bin directory of your Confluence installation directory.

Best regard,

Peter

Hi Peter,

We're not actually using Confluence yet. I was tasked with finding out if this would run on our current setup.

I think that once the software guys get back from hols/site visits, we could probably go through the JVM set up....but it's not something I'm familiar with.

Regards

Andy

This widget could not be displayed.

Why not install a separate JVM only for confluence? You can always install many JVM, and modify start script / registry / env variables to allow each program pick its JVM.

Confluence installer ships its own Java, and its unpacked in a subdir of c:\program files\confluence or equivalent. so ... why other programs will run with this new JVM?

HTH

Thanks Alex, but I'm more of a hardware guy than software, so I'm not too sure I'd be confident enough to do what you suggest.

By default if you install confluence from windows installer or standalone pack, it will provide its own JVM and will not use other JVMs previously installed.

But, take the backup/snapshot as usual if you dont want to take unnecesary risks on your bussiness-critical apps.

HTH

That sounds good, but all of our client machines are running 6.19 too.....Will that make a big difference?

Between 1.6.0_19 and another 1.6.0_XX version there are only bugfixes. They may o may not impact you applications depending on where are that bugs and what your applications are doing. You need to have bad luck to hit one of these bugs, but it's possible.

In the other hand, your vendor (Atlassian) ships confluence with 1.7.x, and the next release will work only with 1.7 JVM (not 1.6 at all) as Peter stated.

I recommend you to use 1.7 because is the version supplied by the vendor, and the installation is easier (you dont have to change anything about jvm). Just guessing ... maybe your client machines are running 6.19 because they defined some kind of policy to use that exact version. This "policy" should be reviewed if they want to install 5.2+ some day in the future.

Confluence 5.1 likely works with 1.6.0_19 as well, if you are interested in using that version.

HTH

Thanks again, Alex.

We use 1.6 across the clients due to a software install that ONLY runs up to that version. I'm trying to push to see if we can get that moved on, but would seem that 5.1 would be the way to go for now....until the other business critical software is updated.

Regards

Andy

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Sep 17, 2018 in Confluence

Why start from scratch? Introducing four new templates for Confluence Cloud

Hi my Community friends!  For those who don't know me, I'm a product marketer on the Confluence Cloud team - nice to meet you! For those of you who do, you know that I've been all up in your Co...

596 views 7 6
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you