Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,364,637
Community Members
 
Community Events
168
Community Groups

Is there currently a problem with API Keys?

I have tried with 3 accounts and a handful of keys in each, and was never able to get anything but 401:

curl -D- \
-X GET \
-H "Authorization: Basic <base64(email:api_key)>" \
-H "Content-Type: application/json" \
"https://my-company.atlassian.net/rest/api/latest/issue/"

Is there some problem with API Keys in Jira?

1 answer

0 votes
Alex Koxaras Community Leader Sep 15, 2022

Place the issue key number after the last "/"

https://my-company.atlassian.net/rest/api/latest/issue/ISSUE-KEY

My problem was with the wrong token because there are two of them: Atlassian Administration -> Settings -> API Keys and https://id.atlassian.com/manage-profile/security/api-tokens

After the token was the right one I got HTTP 405 and that was because of the issue number, as you suggested, thank you!

Like Alex Koxaras likes this
Alex Koxaras Community Leader Sep 15, 2022

Glad to know it worked!

Kindly mark my answer as accepted, in order to help others. Thank you!

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events