Is there a practical limit to the size of an image that Image Effects can be applied to?

I'm trying to apply image effects (curled shadow, in this case) to a 600x428px 600KB JPEG, and after selecting the effect, the spinner comes up, but never completes. Looking at top (this is Confluence 4.3 running on Ubuntu 12.04), there is a flurry of activity for about one second, then that is it, the java process just sits there at 0% CPU utilisation.

I've been able to apply the same image effect to small images without problem, so I'm wondering if there's a maximum size of image that the effects can handle?

1 answer

1 accepted

This widget could not be displayed.

Hi David,

There is actually a hard limit in place for this, that should show an error when you try to apply effects to images over 2,000 square pizels in size. It should look like this:

The image's dimensions are too large to apply effects.
The width and height must be under 2000 pixels.

a 600x428px image should be fine - check you JVM settings and logs to make sure there aren't any errors. Contact our support team if you're having trouble. http://support.atlassian.com'

-Simon

Hi Simon,

Checking /var/atlassian/application-data/confluence/logs/atlassian-confluence.log gives me the following error (trimming off the enormous call stack):

2012-09-07 17:13:37,018 ERROR [http-8090-5] [[Standalone].[localhost].[/].[file-server]] log Servlet.service() for servlet file-server threw exception
java.lang.IllegalArgumentException: Numbers of source Raster bands and source color space components do not match
        at java.awt.image.ColorConvertOp.filter(Unknown Source)

which suggests that Confluence doesn't like my image. I tried opening the original image in Paint.NET, saving it again, and replacing the image on the wiki, but that made not difference. I then tried copying and pasting the image into a new image in Paint.NET and saving it, and this time the image effects applied correctly.

FWIW I just noticed that the image thumbnailer wasn't generating images before either, but with the updated image, thumbnails were generated OK.

Thanks for the info David. It still bothers me that a JPG file threw that error - hopefully you won't have to do this for every image you upload.

So far every image from a particular source (our marketing department) has had the same problem. Images that I've created (e.g. from screenshots) work fine. Thanks again for the help.

The way that your marketing department saves JPG files may make them corrupt. Might be worth going over their export procedure.

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Published Tuesday in Confluence

Add-on evaluation with confluence templates

Atlassian market place contains number of Apps/Addons which improves the capability of out of the box Atlassian products. It is good to follow a plugin evaluation process before install add-ons. So t...

92 views 12 6
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you