It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Is there a known bug with editing office files using the companion app with parentheses in filenames

One of my users brought to my attention that they could not get some attachments to open using the Companion App, after some testing it appears that any of our office files containing parentheses in the filename will not open for editing. Dashes, periods, and spaces all seem to work fine but once you put in a parentheses it falls apart. Is this a known issue or is something going on with my Confluence install?

We are on 6.14.2 and we also use Duo 2fa but Duo doesn't seem to otherwise impact our ability to use the Companion app for editing, I just figured it was worth mentioning.

1 answer

0 votes

Hello there!

Austin, thanks for reporting this behaviour for us. I tried to replicate this locally but the issue was not present.

Here are the file names that I tried:

  • ()MyWordFile
  • MyWordFile()
  • MyWord()File
  • MyWord(File)

None of the filenames triggered the issue. In my environment I have no firewall, proxy or 2FA. This is my environment:

  • Ubuntu 16.04
  • Confluence 6.14.2
  • Client macOS 10.14
  • Firefox 65.0.1
  • Chrome  73.0.3683.86 

With this in mind, I would like to ask a few things:

  1. Has this worked at some point in the past?
  2. What filenames are given to the files? Could you give examples?
  3. Are you able to try the by accessing Confluence with localhost?
  4. Was there any kind of change applied to your environment prior to this issue?
  5. What browser were you using?

Austin, looking forward to your reply!

Diego,

I run Confluence through a reverse HTTPS proxy (IIS 7)

Here are the files I have tried (all files are exactly the same copy, just changed the name)

  • Test.xlsx
  • Test.test.xlsx
  • Test - Test.xlsx
  • Test (Test).xlsx

In the above cases, I am able to open/edit/save every file except "Test (test).xlsx". When I attempt to load it via the Confluence Companion App, the Companion window pops up in the preview pane with the "Editing with Excel" pane, and the details say "Opening file with excel" and the progress never moves. For the other files, it moves past "Opening file with excel" and gives me the status "This file is open in Excel. Once you save your changes, you'll be able to upload the file back to (site name)"

We run Confluence internally so there is no network firewall between me and my Confluence environment (but, again, I do have a reverse proxy).

I have also tested this behavior with .txt filetype and the issue persists.

We just recently upgraded to 6.14.2 from 6.10, so prior to this we were not using the Companion app. In fact the Companion was the main reason for the upgrade, since the old edit in office was unreliable at times and the ability to edit in any program was desirable. The edit-in-office feature (Using WebDAV I believe?) was working when editing files with parentheses in the filename when on 6.10 (when using a browser that supported the feature)

Server environment:

  • Confluence 6.14.2
  • Server 2016
  • IIS 7 reverse proxy with LetsEncrypt certificate
  • Duo 2fa

Client environment:

  • Windows 10
  • Chrome 73.0.3683.86 
  • Firefox 66.0

Not entirely related to the above but is there a feature request board for Confluence or the Companion app? One feature disappointingly lacking is the ability to save/upload as you go while editing files. We would like to be able to upload our changes periodically without then having to close and reopen the editor via the Companion app again

I just tried it from localhost, same story. Also tried bypassing the reverse proxy but I am not given the option to edit files at all, I assume that is due to the reverse proxy config.

I just noticed there are Companion App logs, so I did some further testing. When attempting to load a parentheses laden file, the logs end with a "handling file launch request" message as the last line. Files that work continue on with "download length set at x", then a "companion.openWith.request",and finally a "telling the OS to launch file" message. Checking the .atlassian-companion Cache folder, I can see that a file stub was created but the file is blank.

Not necessarily parenthesis issue. I am also facing similar error with different version of file. The small file .doc etc is opening fine while .docx never does anything

 

Confluence version 6.13

Hello there!

With a little more research, I could find some other examples of this behaviour. Here are possible culprits:

  • Browser Related
  • Proxy Related
  • SSO

The affected browser on the cases I saw were Firefox or Internet Explorer. However, your user has used Firefox and Chrome and in both occasions the feature does not work.

We can still try to bypass the reverse proxy and the SSO. We have documentation on how to bypass the proxy:

How to bypass a reverse proxy or SSL in Application Links

Also, here is the bug report pointing to this issue with SSO:

CONFSERVER-57486 | Edit in App does not work when Confluence is integrated with Custom SSO

Looking forward to your reply!

Was there a resolution to this issue? I'm facing the same problem with Confluence 6.15.9, running on a Windows server behind an Apache reverse proxy.

The links provided by Diego above don't seem to help me that much.

Dalecrtric: yes, the resolution is to not use special chars in your filenames :)

 

I fail to recall exactly what I tested but I believe I ruled out the proxy being at fault. I simply educated my users on the issue and moved on

Thanks for the reply :-)

:-( That's not going to wash with my users as there are a significant number of files uploaded there that include parentheses.

If I get any feedback from Atlassian I'll add it to this post.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

How is your team having fun and bonding, remotely, utilizing Confluence?

Thanks everyone for answering last week’s question. The winner of the random drawing from those who commented is: @LarryBrock I’ll contact you separately with your prize details. This wee...

276 views 9 6
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you