Insert screen capture in Confluence results in broken link

When I try to insert a screen shot or screen capture into a confluence page and save it, it shows a 'broken link' red image once saved. The method currently used is saving the image to the clipboard as opposed to saving it as a file to the desktop on a Mac, and then pasting it in confluence. Would really like to be able to do this as opposed to saving each screen capture as an image and then dragging and dropping.

1 answer

0 vote
Ann Worley Atlassian Team Jun 14, 2017

On my Mac, I tested pressing Command-Control-Shift-4, then pasting into the editor and it worked for me. I tried on Confluence 6.2.x and Cloud, with Chrome.

Please let me know on what version of Confluence and browser you are experiencing this behavior.

I also wanted to double check that the image looks ok in the preview and only turns into a broken link after saving?

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Kesha Thillainayagam
Posted Apr 13, 2018 in Confluence

We want to hear how your non-technical teams are using Confluence!

Hi Community! Kesha (kay-sha) from the Confluence marketing team here! Can you share stories with us on how your non-technical (think Marketing, Sales, HR, legal, etc.) teams are using Confluen...

2,486 views 25 10
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you