Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Impossible to type non-emojis?

With the new editor, it appears to be impossible to type series of characters that Confluence wants to change into emojis, at least on macOS. Try typing B) and confluence helpfully assumes that I want a smiley face with sunglasses instead of a continuation of my A) from the line before it.

I've read the documentation here https://support.atlassian.com/confluence-cloud/docs/keyboard-shortcuts-markdown-and-autocomplete/#Keyboardshortcuts,markdown,andautocomplete-neweditor

I have tried Esc, cmd+z, ctrl+z, delete, clicking away. None of them make the emoji revert to actual text.

I have checked Profile Photo > Settings > Editor.  All the options to disable autocomplete are greyed out and disabled.

The only thing I've found to work is copy-pasting the string I want to type into the editor.

Is there ANY way to disable this? Is there ANY shortcut to cancel the auto-replace?

2 answers

Hi @dougw ,

It looks like a bug... What you can do is using a small letter (so you have to type b) ). Another option is using space between letter B and bracket ), and after typing the bracket removing the space.

 

I have checked Profile Photo > Settings > Editor. All the options to disable autocomplete are greyed out and disabled.

 

Please check it once again. Did you click Edit button below the options to make any changes and select checkboxes? I selected these checkboxes but I don't see any changes on the page. Still B) is replacing on sunglasses emoji.

Which browser do you use?

Best regards,

Sophie

Ah okay well that solves the mystery of those settings. I assumed that button was to submit the changes but you are correct, it enables them.

That said, yeah those settings do not appear to actually change emoji auto-replace behavior so this still doesn't solve the problem.

I appreciate the ideas, but of course typing something I don't want just to avoid an emoji isn't really a solution.  In my example, yes, maybe I'm able to use lowercase letters or maybe not.  There are lots of cases where it's not possible.

Ex. How would I cite this legal document? (18 U.S.C. § 8)

I am on macOS Catalina using Chrome.

Best

I agree that this is undesirable behavior.

Best: Show emojis as hints we can pick if we want them. (In an issue tracking system emojis are rarely useful)

OK: Give us some way to escape or Ctrl+Z out of the emoji

Worst: Jira today!

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
PERMISSIONS LEVEL
Site Admin
TAGS
Community showcase
Published in Confluence

Miss the Confluence demos at Team 21? Watch them here!

Phew, Atlassian Team 2021 blew by. With dozens of demos and a handful of keynotes, you may have missed some of the awesome Confluence Cloud sessions. Don't' worry, you can watch them all here or on Y...

274 views 2 6
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you