It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Importing Word documents does not bring in the line breaks

I am importing a word document to Confluence which has few line breaks in between. Let us says there are 3 lines each with a line break like thus:

Line1

Line2

Line3

But when imported to Confluence using the Word importer, everything is appearing without the line breaks.

Line1
Line2
Line3

Is there a configuration that we can do to override this? How can we get the line breaks ported across?

4 answers

1 accepted

1 vote
Answer accepted

I had a similar problem, and if IIRC, I had to replace the line breaks with \\ and then newline, in the word doc before the import.

Can't believe that works but there you go! Thanks Jamie. I only spent a couple of hours on this :)

Cool stuff - same trouble here. Thanks !
@Jobin - use Webdav + Notepad++ Search&Replace function to fix this with imported content :) Maybe that saves you a bit of time

I have the same problem, I think, Word end-paragraphs are imported without extra spacing, meaning our people are making manual after processing inserting a line feed followed by a delete to have the natural Confluence space appearing after a paragraph. We are now to import thousands of pages and this manual processing will take weeks. @Jamie Echlin [Adaptavist] and @Jobin Kuruvilla [Go2Group], I can't get your trick working, I am probably missing something. What exactly do you mean by "replace the line breaks with \\ and then newline"?

Confluence 4.2 btw!

I have the opposite problem, I use the "No spacing" format in word and it imports that way but if I then edit the page in confluence it uses it's own line spacing which has a much bigger gap between lines and I can find no way to change that so my pages start having mixed formatting. I also do a lot of LDAP filter documents and the import can not handle that and using {noformat} in the word doc just gets ignored so I have to try and do a lot of manual editing after the fact. It ends up being easier to just attach the doc as an attachment, which means I might as well dump confluence and go to sharepoint.

It was much easier under wiki markup.

Using Confluence 6.3.1

Jamie's solution didn't work for me....but it was close to the actual solution. Between reading Jamie's post, and the info I found at https://confluence.atlassian.com/display/CONF34/Working+with+Text+Breaks ,

I realized the trick was you had to put \\ then a space then another \\. So in Word, my method became

find: ^p

replace with: \\ \\^p

The ^p (which means paragraph or line break to Word) in the 'replace with' portion is not strictly necessary, Confluence will still import this with the line break. However, it will look much better in Word if you keep these in the doc, and they won't make any difference to Confluence, as it seems to ignore these.

BTW, I'm surprised the Confluence developers couldn't have written their Word import to do the ^p conversion to line break properly. Seems like it should have been a no-brainer, Yet it caused me a to lose a ton of time to figure out how to do a workaround using the \\ \\ trick.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Confluence Cloud

What's New in Confluence Cloud – July 2020 Edition

Here’s another edition of “What’s New” this month in Confluence Cloud. Quickly (and more easily) adjust permission settings We know that sometimes the layers of space permissions and page restric...

686 views 3 7
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you