Images disappeared

Ella Sparks July 13, 2018

Hi,

I have just been looking through my Confluence space where the Help manuals are stored for my company and have noticed that some images are not there anymore. Is there any way to retrieve these images as I have not done anything differently.

They don't seem to be listed as attachments but I can see the URL when the small icons are clicked.

Kind regards,

Ella Sparksimage.png

7 answers

3 votes
Danny November 14, 2019

I have been experiencing this issue frequently and it is VERY annoying. I've lost 10+ images and it happens almost every time I save the page. 

Dilraj Singh
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
October 7, 2022

It's been 3 years, is there anyone working to fix this, or should we just go back to GitHub Wiki? @Mark Segall 

stefanovicova
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
February 16, 2023

This keeps on happening very often , is there any fix??? 

1 vote
George Rai
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
June 10, 2020

I'm having the same loss of copy and pasted images into Confluence.  I do nothing and the last version of the confluence page loses all the graphs of results  that I have taken days to put together. Its making adverse waves in the company I work for as this is quite a serious loss of work.

At the moment I'm having to roll back to the previous version of the page to partially recover the graph images. I am using Windows Snip to do the copy and pasting into Confluence. Nothing special.  

I'm also losing intra-page links to book and article references.  

Its quite disturbing to keep randomly losing work.   Its almost as if the  images were stored in a temporary caching area and the cache has been cleaned (because it was temporary).    Infoselect 9, a free form data base,  fell into this problem. I located  the  temporary  files  by searching the hard disk history of most recent file additions to discover the reason for the  problem. 

 

Associated Information (Storage Issues for images)
https://confluence.atlassian.com/doc/attachment-storage-configuration-166876.html?_ga=2.22778361.333565211.1591834513-510853686.1587364024 

 

Confluence Attachment Migration – The Safe Way

https://www.scandio.de/blog/de/2013/05/confluence-attachment-migration-the-safe-way-2

 

I don't have an answer to this problem yet  (11 June 2020) 

 

 

W Bot August 31, 2020

Sane problem here George

1 vote
Ella Sparks July 13, 2018

The page is unversioned so when looking back at previous versions, nothing changes.

http://support.crowderconsult.co.uk/confluence/download/attachments/10527309/styling%20right%20click.png?version=1&modificationDate=1484039009324&api=v2

This is the URL for one of the missing images. 

To enter those images, I simply uploaded the files using the insert files and images button, I am unsure how that would then link to the folder on my desktop. My desktop folder still has the image in the same folder too so that's not changed.

Jonathan Smith
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
July 13, 2018

When uploading from your desktop, it will store on the image on the server - not reference a link back to your desktop.

It sounds like the image (attachment) itself was removed from your page.

Try this:

  1. Insert a new image onto the page by using the steps you described above.
  2. Publish the page.
  3. Click the attachments icon and see if your new image displays. If your old images do not display on this page, it looks like it got deleted.

images.jpg*Shameless plug of my little booger

Jonathan Smith
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
July 13, 2018

Additional thought, what is your image extension? Your image file type might not be supported as well causing a "broken image" icon. 

Jonathan Smith
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
July 13, 2018

.png is fine. 

Ella Sparks July 13, 2018

Before trying that, can I unpublish a page, I wasn't going to publish any pages yet?

I have tried adding the same image to the page and it did not refresh the old image, it just added it as a new image and now is shown in the attachments.

It is okay for now to insert these missing images as I have saved them externally, I am just worried in case this happens with images I have inserted as a screenshot and not saved anywhere else.

 

I used .png files for my missing images.

Those images were put in last year and have not been touched since, the only thing I have done recently is update the add ons in Confluence.

Jonathan Smith
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
July 13, 2018

If the page is now published, change the page restriction so only you can view: Unrestrict when ready.

Ella Sparks July 16, 2018

That unfortunately didn't show me the old images. It only displayed the new ones.

I'm just confused as to how they got deleted when nothing has been changed. It concerns me if this happens again in the future, as there are thousands of images in one space.

0 votes
Antoine _Klee Group_ November 17, 2021

Hi, I have the same issue in Confluence Datacenter. The images suddenly disapeared. Fortunately let's say they still appear in the "attachements" section. How to make them appear again.

Antoine _Klee Group_ November 18, 2021

Alright so my solution was just to download all attachments then import them back using the wizzard. I have now two versions of the same attachment but at least they are displayed on the pageimage.pngimage.png

David Manison
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
January 18, 2022

I've had same issue but seemed local to my machine, I cleared cache and everything back to normal without doing anything else !!

Like Jonathan Smith likes this
0 votes
Dustin Ghia
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
June 11, 2021

Yo should review if the image is really loaded.

0 votes
Birgit Strompen April 22, 2020

we had the same problem twice

and in one occasion there was the problem that the confluence site has been edited in the IE, normally we are editing with chrome.

0 votes
Jonathan Smith
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
July 13, 2018

If the images were pasted/added to your page, do they return if you go back to a previous page version?

If the images are coming from a hard coded URL, sounds like that directory/folder/file got moved, renamed, or deleted.

thomas.jean-louis
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
February 21, 2020

Same problem, and yes, previous versions of the document still have the pictures. It seems that in a version, all the pictures of a page were scrapped. We reverted to the previous version this time, but we have many of those, and this is becoming very frustrating

Like Dilraj Singh likes this

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events