Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,301,310
Community Members
 
Community Events
165
Community Groups

IIS proxy settings does not work after Confluence upgrade

Problem:

I have upgraded Confluence from 6.15.7 to 7.13.0 on a Windows VM. The Confluence runs fine on built-in Apache server after the upgrade and it is accessible via http://localhost:8190 . However, I want to set up the reverse proxy settings on IIS as well so that it can be accessed via domain url https://confluence.domainname.com.au. I have set up URL rewrite rules and followed the steps from the kb https://confluence.atlassian.com/kb/proxying-atlassian-server-applications-with-microsoft-internet-information-services-iis-833931378.html . But when I try to access the Confluence via url, I get a blank screen. There is no network activity when viewed via the Dev Tools on the browser.

The rules in the web,config are 

<?xml version="1.0" encoding="UTF-8"?>
<configuration>
<system.webServer>
<rewrite>
<rules>
<clear />
<rule name="HTTP/S to HTTPS Redirect" enabled="true" stopProcessing="true">
<match url="(.*)" />
<conditions logicalGrouping="MatchAny" trackAllCaptures="false">
<add input="{HTTPS}" pattern="^OFF$" />
</conditions>
<action type="Redirect" url="https://{HTTP_HOST}/{R:1}" redirectType="SeeOther" />
</rule>
<rule name="jira-localhost-rewrite" stopProcessing="true">
<match url="(.*)" />
<conditions logicalGrouping="MatchAll" trackAllCaptures="false" />
<action type="Rewrite" url="http://localhost:8190/{R:1}" />
</rule>
</rules>
</rewrite>
<security>
<requestFiltering allowDoubleEscaping="true" />
</security>
<httpRedirect enabled="false" destination="https://confluence.domainname.com.au/" />
<caching enabled="false" enableKernelCache="false" />
</system.webServer>
</configuration>

 

The Connector settings is

<Connector port="8190"
connectionTimeout="20000"
redirectPort="8443"
maxThreads="48"
minSpareThreads="10"
enableLookups="false"
acceptCount="10"
debug="0"
URIEncoding="UTF-8"
protocol="HTTP/1.1"
proxyName="confluence.domainname.com.au"
proxyPort="443"
scheme="https" />

 

Any help would be greatly appreciated.

1 answer

1 vote
Brant Schroeder Community Leader Jan 22, 2022

@David Bradley Were you able to get your IIS proxy working?  

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
SERVER
VERSION
7.13.0
TAGS
Community showcase
Published in Confluence

An update on Confluence Cloud customer feedback – June 2022

Hi everyone, We’re always looking at how to improve Confluence and customer feedback plays an important role in making sure we're investing in the areas that will bring the most value to the most c...

421 views 2 13
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you