I have a corrupted global space that I cannot delete.

One of my other admins created a global space called "Test Space" with short name "TS".

He then tried to delete it and got back the "Space removal long running task - In Progress". The "Removed space" green bar moved across in 5 seconds and he got the: Completion: 100% complete.

But the space still seems to exist. When I went into the "Space Admin"->"Permissions" section. It shows there are no administrators. I added our administrator group AND my own name as full space admin.

Tried deleting the space again ... same result. And again there are no space admins listed.

I assume the space is corrupt but I'm at a loss to figure out how to remove the space.

Anyone have any ideas?

9 answers

This widget could not be displayed.

Hallo there Jonathan

Are you running Confluence 4.2? This sounds like a bug recently reported: https://jira.atlassian.com/browse/CONF-26122

Cheers, Sarah

Yup ... we're on 4.2.8 I'll be looking for 4.2.13 as soon as it comes out. In the meantime are there any work arounds for this? I didn't see any posted in the bug report you mentioned.

Thanks for your help!

This widget could not be displayed.

Hi Jonathan,

It is a bit messy to delete a space directly from your database, however it is possible. Please try the steps provided here and ensure that database backup is available before trying to update your database directly:

https://confluence.atlassian.com/display/CONFKB/How+to+Manually+Delete+a+Space

Hope it helps.

Cheers,
Septa Cahyadiputra

This widget could not be displayed.

See if it can be removed via the remote APIs - Confluence Command Line Interface - removeSpace . Sometimes this can avoid the code path that has a bug.

This widget could not be displayed.

Hi Jonathan,

Can you do a space export of a space you're having trouble deleting and attach it to CONF-26122? This might help us diagnose the problem. Can you also check your Confluence logs to see if any errors were reported there?

Thanks,
Niraj.

Niraj,

I've asked Mike to get this export to you ASAP. Let us know if there is anything else we can do for you. Thanks for your help!

-Jonathan

This widget could not be displayed.

Thanks to everyone who responded! I'm going to have my Confluence Admin (Eric Brady) take over the trouble shooting from here so he should be monitoring/reponding to this thread.

Thanks again,

- Jonathan

This widget could not be displayed.

We're still having trouble reproducing the problem. If anyone experiencing issues removing a space could download and install the diagnostic patch mentioned in CONF-26122, that will help us a great deal. Thanks!

This widget could not be displayed.

There is a known issue with the Adaptavist Descendant Notifications Plugin that can cause spaces to not be removed. See CONF-26024.

This widget could not be displayed.

We had a similar issue when we upgraded Confluence from 4.1.6 to 4.2.8. We didn't have Adaptavist Descendant Notifications plugin installed but found that the issue was caused by the Confluence sub space plugin.

We disabled the plugin and were able to delete spaces again. However, this broke the default dshboard as it wasn't displaying any of our spaces at all. We had to direct users to the Space Directory so that they could get to their respective spaces.

This widget could not be displayed.

Hi Edward,

Thanks for letting us know about the subspace plugin. It looks like it has been reported before at CONF-26255.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted yesterday in Confluence

Why start from scratch? Introducing four new templates for Confluence Cloud

Hi my Community friends!  For those who don't know me, I'm a product marketer on the Confluence Cloud team - nice to meet you! For those of you who do, you know that I've been all up in your Co...

208 views 2 4
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you