Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

I continue receive "Your Work is safe, but there's an issue" error

While trying to create child pages in our team confluence site, I continually get this error and the child page does not publish.  I have cleared my cache, tried in Chrome, Chrome Incognito mode and Edge with no success.  Can you p[lease assist? 

 

Thank you

5 answers

1 accepted

Hello Everyone,

Thank you for all the information provided.

Based on the last reports and health checks done so far, we did not identify any global issues in the creation of Confluence child pages that could be causing the problem.

That being said, the error "Your Work is safe, but there's an issue" usually happens when another page with the same name is already created on the Confluence site, something that can be checked in the network tab of the browser Devtools, as explained by Darrel previously. We understand how the error message above can be misleading, so we created the following bug to change it for something more specific:

Generic message when a page already has the same title 

Feel free to vote and watch the bug to increase its priority and also receive notifications about any updates.

If that's not the problem you're facing, please feel free to post the errors found in the console/network tab of your browser's development tools so we can further troubleshoot the problem.

For any other previous problems/outages with Confluence application, please check the public documentation below:

Confluence Status 

Thanks!

Hello All,

Also, to add to comment from @Petter Gonçalves  we are tracking this as a new BUG at the following link to get the generic error message updated to reflect the actual cause of the error, make sure to follow the request if you want to receive updates on the status of the fix:

Regards,
Earl

I can see, it is going to be released early... great job everyone, thank you :)

I received the same message, but it doesn't seem to be because of the overlapping title (I have deleted the page, created a new one, got a new (random) title and still cannot publish).

Do you have any other hypotheses so I can test around? 

@Annabel Nguyen can you analyse your problem with steps provided in my thread below? You need to check it with dev console in your browser...

I got the same error but I'm assuming it's generic and could be related to multiple causes. Mine was because I was trying to create a new page with the same title. 

Network tab response "A page with this title already exists" 

Thanks for the suggestion Martin

Hi @Darrel thank you for your feedback, so the informaiton about "page with the same title" is not displayed on dialog, but only in networ tab, right?

Yeah, thats correct Martin :) 

Like Martin Bayer likes this

I had encountered the same problem today and was trying to find a workaround. The error message "Your Work is safe, but there's an issue" is misleading. 

Thanks @[deleted] it really helped!

Like Joe Pakenham likes this
Deleted user Jan 26, 2021

Same here. @Darrel thank you for your investigation it saved me tons of time. 

I am getting this same issue. I cannot create any child pages in my Confluence space.

Are there any updates to this? I'm getting the same error and have tried everything: clearing the cache, creating a new page, copy-pasting the contents, etc. Nothing fixes it.

Have you checked the Label colour?

Last time I made a silly mistake that I accidentally used one colour for 2 different label name. Simply deleted one and it worked like a charm (wish Confluence could give more specific error notification though :)

I tried to post to Atlassian team (moderators of the community forum) once again.

Hi @Tani Theiler , welcome on the community. I didn't experience this problem, but it is always good to start with at least some analysis.

Can you go to dev-tools in your CHrome browser (F12 button) and open network tab? Try to save child page after that and you should see some error in this network tab.

Post the message here, or just screenshot of the error should be sufficient.

child-src https: chrome-untrusted://new-tab-page/chrome untrusted://kaleido scope/;object-src 'none';script-scr chorme://resources chrome://test chrome://kaleidoscope 'self' 'unsafe-inline' https:; frame-ancestros 'non';

Hey @Tani Theiler

I believe the information you provided above is not an error on the browser console, but just one of the events of the page.

Please, try to follow the steps below to capture the error log in the development Consolee of your browser:

  1. Using Chrome, click on the drop-down View > Developer > Javascript Console
  2. Navigate to Confluence and reproduce the error, checking the last event displayed in the Console. The should be red-colored and explicit return an error code

Additionally, I didn't find any reports about this error on Confluence, so it might be a new error message. 

We'll be waiting for the error to better understand what might be the root cause of the issue.

@Tani Theiler I just tried to create page with existing name and error message looks correctly. So it is really hard to say what is your exact issue @Tani Theiler .

I also see `Could not parse response from rest API: com.atlassian.confluence.api.service.exceptions.BadRequestException: A page with this title already exists` only if I inspect the page. No page of the same title exists, so this is a bug on the Confluence side.

I'm getting the same error and unable to proceed with my release notes. the error I'm getting on the network tab is; 

"com.atlassian.confluence.api.service.exceptions.BadRequestException: A page with this title already exists".

it seems to be random as some pages get published while some dont. highly frustrating

@Tani Theiler @Arun Perera @Erin Boyle @[deleted] @Darrel I tried to notify @Petter Gonçalves from Atlassian team. It really looks like a bug in parsing response from server.

Hey @Martin Bayer _MoroSystems_ s_r_o__ is there any progress on this? I keep getting the "Your Work is safe, but there's an issue" error today, only in one specific space.

Hi @Paweł Rozumek I have no information from Atlassian by now. Can you analyze your "root" problem with steps provided by @Petter Gonçalves earlier in this thread?

It is good to have as much information as possible.

Hi @Martin Bayer _MoroSystems_ s_r_o__ , here is what I got as response. 

{"statusCode":400,"data":{"authorized":false,"valid":true,"errors":[],"successful":false},"message":"com.atlassian.confluence.api.service.exceptions.BadRequestException: Error converting ADF to storage format"}

Tried to find the answer in Atlassian community but none available. Huhmm, do you have any idea about this? 

Hi @Annabel Nguyen I'm not sure what is the exact problem, but "ADF" is "Atlassian Document Format" so I guess it is something what is sent from your browser to the server and it can't be stored to storage format (probably format used by the database).

I would suggest you to check your text for some "special" characters. 

longle I'm New Here Oct 06, 2021

Hi @Martin Bayer _MoroSystems_ s_r_o__ , I encountered the same situation.

Confluence respond me "Error converting ADF to storage forma"

I tried to do the way what u suggested but it doesn't work. Hmm, can u help me by another solution for this problem?

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
TAGS
Community showcase
Published in Confluence

Confluence Mythbusters: Does Atlassian even use Confluence?

Hi, Confluence collaborators! As part of #Confluence-Collaboratory month, we’ve created a very special Mythsbusters segment, where we're dive into an interesting myth and uncover the truth behind i...

1,696 views 7 32
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you