Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,301,294
Community Members
 
Community Events
165
Community Groups

How to restore deleted Confluence space without a backup?

Edited

We tried to delete a confluence space, but when my friend pressed "delete space" they were promptly sent to a different space. Then they clicked "delete this space" at confirmation page and only then I noticed, that we're in a different space. Another name, another icon. Somehow, delete button sent from a freshly created space into an old one with a bunch of work data.

While not having a backup is a tragic oversight, this situation became possible due to a bug, as they were pressing "delete space", while being in a different one. 

I don't know how to prove or demonstrate this bug, as I couldn't reproduce it on this account and we didn't record our video conference. Please, find it and fix it for other people in the future.

If you know, how to restore a space without backup, please tell.

P.S. Maybe make mandatory XML backups on deletion, or store them for a while longer before actual deletion happens.

5 answers

1 accepted

Comments for this post are closed

Community moderators have prevented the ability to post new answers.

Post a new question

4 votes
Answer accepted

Hi @Elaine Heart ,

Thanks for posting and welcome to the community.

I can understand your feeling and your situation as you have faced this.

Unfortunately, deleting a space is permanent so it's always suggested to archive a space instead of deletion - https://support.atlassian.com/confluence-cloud/docs/delete-a-space/

Now, I think that XML backup - https://support.atlassian.com/confluence-cloud/docs/export-content-to-word-pdf-html-and-xml/ is not mandated  because this might again increase the overall complexity and in case any deletion backup would be mandatory if the user is not also looking for that.

I also had this scenario just happen to me. I know absolutely what space I was intending to delete and upon hitting delete it switched over to the previous space I was viewing (which was new and had tons of work already put into it) and deleted the new space! Clearly there is a bug occurring. I've reached out to Atlassian support just praying they can somehow retrieve it. :( 

So apologies - no solution, but wanted to acknowledge there appears to be a bug

Hi!

It happened the same to me - i deleted a space with a bunch of work data. And i definitely tried to delete other space. When i clicked on confirm button in correct space, i was redirected to incorrect space (i saw it in address bar) and then it was deleted.

Can you explore it, please?

1 vote
Sol Salas I'm New Here Feb 09, 2022

Hi! It happened the same to me today. Is there any way to contact Support for this kind of issued? As it seems to be a bug...?

 

Thank you!

I believe I just faced this situation today.  I was attempting to delete one space, but it deleted the space that I was looking at prior once I confirmed.  We are attempting to recover a backup now, but this is something Atlassian needs to explore.

Comments for this post are closed

Community moderators have prevented the ability to post new answers.

Post a new question

DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
FREE
TAGS
Community showcase
Published in Confluence

An update on Confluence Cloud customer feedback – June 2022

Hi everyone, We’re always looking at how to improve Confluence and customer feedback plays an important role in making sure we're investing in the areas that will bring the most value to the most c...

421 views 2 13
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you