Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

How to get rid off vertical scroll bar when working with sections

Hi,

I'm working with sections and lay outs and currently I have a problem with a vertical scroll bar. Scroll bar appears every time when I use page lay out (2 column section) and insert tables. I would expect that section will enlarge dynamically. I'm also attaching an example, one edit view the other published view.

I would like to remove the scroll bar.  Do you know how can I do it?

Many thanks!!

Petravertical scroll bar edit mode.pngvertical scroll bar published mode.png

3 answers

I just had this same problem. I used a brute force method to determine whether it was formatting: I did a select all in the offending section, and did Clear Formatting. This removed the vertical bar. Then I added the formatting back and teh vertical scroll bar came back.

In the end, for me, it was cased by a Heading 1 as the format for the last line in the section. When I added a Paragraph format line after the heading, the vertical bar went away.

Thank you, this fixed the same problem for me!

Like # people like this
0 votes
Zak Laughton Atlassian Team Jul 30, 2018

Hi Petra!

That is interesting that you're getting that vertical scroll bar. I typically see sections like that behave as you said they should – they expand vertically to fit the content. I also wasn't able to reproduce the scrollbar behavior when I created a page similar to the one in your screenshot.

I have a couple questions to help understand the issue better:

  • What version of Confluence are you using?
  • Can you paste the storage format from a page with just the tables that experience this issue? (ellipsis > View storage format) This will show all content on the page, including any page elements that may be causing a scroll bar.

Thanks!
Zak

I'm experiencing the same problem. When I use headings at the top of sections in a template I get these vertical scroll bars that do not appear to perform any useful function, but they do make the page ugly and confusing. I've attached a pair of screenshsots - how the page looks and how the page is formatted.

how it looks.PNGhow its formatted.PNG

Hi Zak,

I've also noticed this quite a bit lately. Leaving the last line within the column in a paragraph rather than a heading format doesn't seem to make any difference for me. I was wondering if it may be related to whether a column contains other macros as opposed to plain text? I haven't quite been able to land on the right combo of factors to consistently re-create the issue though.

I've attached a few screenshots (some edits and to obscure identifying info) a section of the storage format below.

We're on Confluence Server 6.15.6

Any suggestions welcome as it really does look pretty ugly on screen :-(vert-scroll-edit.pngvert-scroll-view.png

<p><br /></p></ac:layout-cell></ac:layout-section><ac:layout-section ac:type="two_right_sidebar"><ac:layout-cell>
<p><br /></p></ac:layout-cell><ac:layout-cell>
<p><br /></p></ac:layout-cell></ac:layout-section><ac:layout-section ac:type="two_right_sidebar"><ac:layout-cell>
<p class="auto-cursor-target"><br /></p><ac:structured-macro ac:name="section" ac:schema-version="1" ac:macro-id="6076277d-c384-4183-a95b-fc1bc013724b"><ac:rich-text-body>
<p class="auto-cursor-target"><br /></p><ac:structured-macro ac:name="column" ac:schema-version="1" ac:macro-id="69290292-e644-4b00-99ad-11492b84f760"><ac:parameter ac:name="width">40%</ac:parameter><ac:rich-text-body>
<h2>Recent updates</h2>
<p><ac:structured-macro ac:name="recently-updated" ac:schema-version="1" ac:macro-id="96b5d224-5f5e-4c8b-984c-931438136c03"><ac:parameter ac:name="types">page, comment, blogpost</ac:parameter><ac:parameter ac:name="max">5</ac:parameter><ac:parameter ac:name="hideHeading">true</ac:parameter><ac:parameter ac:name="theme">concise</ac:parameter></ac:structured-macro></p>
<p><br /></p></ac:rich-text-body></ac:structured-macro>
<p class="auto-cursor-target"><br /></p><ac:structured-macro ac:name="column" ac:schema-version="1" ac:macro-id="9a8f1c3e-0f16-4f15-a6dc-ae6331938bda"><ac:parameter ac:name="width">40%</ac:parameter><ac:rich-text-body>
<h2>Active contributors</h2>
<p><ac:structured-macro ac:name="contributors" ac:schema-version="1" ac:macro-id="11217e8c-1c9d-4a08-b39d-78856494a557"><ac:parameter ac:name="mode">list</ac:parameter><ac:parameter ac:name="scope">descendants</ac:parameter><ac:parameter ac:name="limit">5</ac:parameter><ac:parameter ac:name="showLastTime">true</ac:parameter><ac:parameter ac:name="order">update</ac:parameter></ac:structured-macro></p>
<p><br /></p></ac:rich-text-body></ac:structured-macro>
<p class="auto-cursor-target"><br /></p></ac:rich-text-body></ac:structured-macro>
<p class="auto-cursor-target"><br /></p></ac:layout-cell><ac:layout-cell>
<h2>Attachments</h2>
<p><ac:structured-macro ac:name="attachments" ac:schema-version="1" ac:macro-id="2a3f4c34-7810-45c7-9b87-defd085e571c"><ac:parameter ac:name="old">false</ac:parameter><ac:parameter ac:name="patterns">*.pdf,*.docx,*.xlsx,*.pptx,*.zip</ac:parameter></ac:structured-macro></p></ac:layout-cell></ac:layout-section><ac:layout-section ac:type="single"><ac:layout-cell>
<p><span style="color: rgb(255,255,255);">space</span></p></ac:layout-cell></ac:layout-section><ac:layout-section ac:type="single"><ac:layout-cell>
<p class="auto-cursor-target"><br /></p><ac:structured-macro ac:name="pagetreecreator-default-value" ac:schema-version="1" ac:macro-id="dbff2ac7-2ff3-4a96-a88c-9c444bc55c60"><ac:parameter ac:name="ptc-tag-id">__Client__</ac:parameter><ac:parameter ac:name="ptc-default-value-hidden">true</ac:parameter><ac:rich-text-body>
<p>APAM</p></ac:rich-text-body></ac:structured-macro>
<p class="auto-cursor-target"><br /></p><ac:structured-macro ac:name="html" ac:schema-version="1" ac:macro-id="960076b2-1e55-491f-a95a-d85f1dfbedac"><ac:plain-text-body><![CDATA[<script>
jQuery(document).ready(function() {
jQuery(".external-link").attr("target", "_blank");
});
</script>]]></ac:plain-text-body></ac:structured-macro>
<p class="auto-cursor-target"><br /></p></ac:layout-cell></ac:layout-section></ac:layout>

 

 

 

Like Hugh Bathurst likes this

Hi everyone,

I recently had the same issue and eventually found that it came down to monitor settings and browser preferences. 

I'm using Chrome, which is where the vertical scroll bar issues appeared. Using IE, the horizontal wrap was a bit different forcing a scroll bar to appear.

I found that the Windows Display Settings had applied the "Recommended" Scale and Layout for the external monitor I was using, in this case it was zooming to 125%. Setting it back to 100% removed the scroll bars in both browsers.

You might also want to check whether the zoom has been changed at the browser level.

Hope that helps!

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

What do you think is the most *delightful* Confluence feature? Comment for a prize!

- Create your own custom emoji 🔥 - "Shake for Feedback" on mobile 📱 - An endless supply of GIFs via GIPHY 🤩 Is there anything quite as nice as a pleasant surprise? Comment below with what...

408 views 23 8
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you