Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,457,458
Community Members
 
Community Events
176
Community Groups

How to embed a Jira issue/filter macro within Expand macro on confluence?

Hi,

I am trying to embed a Jira filter/issue macro within an Expand macro on a confluence page. Jira filter/issue macro is to display all the details like portfolioChildIssues of a feature and i want this to be collapsable/expandable. So trying to embed this within Expand macro but its not working. Jira issue is always ending outside the Expand macro. Is it like the latest version of Jira/Confluence not supporting this? Any help is appreciated.

Thanks

6 answers

2 accepted

0 votes
Answer accepted
Rilwan Ahmed Community Leader Jun 01, 2022

Hi @Rajendar Akkala ,

Welcome to the community.

You need to add Jira filter/Issue macro inside the boundary of Expand macro. Attached a screenshot for your assistance.

image.png

Yes Rilwan, i am adding the Jira filter/issue macro inside the boundary of Expand macro but once the 'Insert' is clicked on Jira filter/issue macro, end result is ending outside the macro. 

Rilwan Ahmed Community Leader Jun 01, 2022

Please share the screenshot from "View Source"

i.e. Open the page, click on 3 dots on the right top  --> Advanced Details --> View source

image.png

Source should be like as below
image.png

Right, but for me its showing as belowunnamed-4.png

Like shannon_woodson likes this
0 votes
Answer accepted
Brant Schroeder Community Leader May 31, 2022

@Rajendar Akkala Welcome to the Atlassian community

I am able to have a Jira issue macro within a expand macro without issue.  Can you share a screenshot of the issue you are having? 

Thanks Brant for the reply. Here are the screenshots.

1) Inserted a Expand Macro

unnamed.png

2) In the above Expand macro i tried inserting another macro using /Jira or the + (Insert) symbol at the top and used the below Jira issue macro

unnamed-2.png

3) After inserting the above macro, it is showing as below, i.e. Jira macro is ending up outside the Expand macro.

unnamed-3.png

 

Could be that I'm making some mistake somewhere. 

Thanks

Brant Schroeder Community Leader Jun 01, 2022

@Rajendar Akkala what browser are you using?  

Brant, its microsoft Edge

Brant Schroeder Community Leader Jun 01, 2022

Can you use chrome or firefox and do you see the same behavior?

Tried in chrome and it's the same issue like in Edge browser. Noticed that Expand is working for the embedded Jira filter/issue macro, if the JQL for Jira filter is simple like "key=something'. When i use query using 'PortfolioChildIssuesof(something) its resulting in the output to be outside of expand macro boundary.

Brant Schroeder Community Leader Jun 01, 2022

Are you using a filter that contains the portfolio child function or are you typing it in?

Brant, here is what i am doing

created a Expand macro

Inside the Expand macro boundary, typed in /Jira and opened the Jira issue/filter macro. 

In the Jira issue/filter macro, typed in the PortfolioChildIssuesOf query to fetch all the stories tied to a feature.

As i click Insert for the above Jira issue/filter, the result for the PortfolioChildIssues is creating the result with the stories outside of Expand Macro.

Im facing the same issue where upon clicking insert, the the Jira macro will be placed on the outside of the expand macro. Any advice would be greatly appreciated

tom.l I'm New Here Aug 03, 2022

Same for me. Very disturbing issues solution would be great.

0 votes
Brant Schroeder Community Leader Nov 29, 2022

@Roger Tabet @shannon_woodson @tom.l Can you provide additional information about your issue?   There are certain combinations, additional apps, etc. that cause this not to work.  Are you embedding it in a table, do you have apps installed that you are using?  

I am also having the same problem, using Confluence Cloud. To be more specific though, I only see this happening when I have the expand macro inside of a table row. When the expand macro is outside of a table and just somewhere on the page, I can successfully add the jira filter (even advanced ones that return multiple issues) inside the boundaries of the expand macro.

0 votes

Facing same problem

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events