Are you in the loop? Keep up with the latest by making sure you're subscribed to Community Announcements. Just click Watch and select Articles.

Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


How to change width of last table column?


It seems a bug. The last table column boundary can be selected, the correct cursor appears, but dragging it does not do anything.


using the description of problem from another question 

2 answers

I found a workaround>

in table with multiple columns where you want to resize the last col size

  1. create extra new column before the last column
  2. adjust the width of this new column to target size
  3. (copy data from last col to new col)
  4. then delete the last column

the size of the last column is changed without influencing the previous cols sizes.. 

Yep. Been doing this too. This is most definitely a bug (inability to resize last column in a table) and should be fixed. That said, I don't think I can report bugs for some reason and this forum is all I've got?

Like Erik Anderson likes this

This looked like a promising idea, and I gave it a shot -- but no joy.  :(  

For unknown reasons (likely an update to Confluence Cloud?), some time in the past two weeks, tables on one of our pages are now too wide -- they require sideways scrolling to read, as the column widths are wonky.  I've tried multiple times to fix the widths, but to no avail.

Trying your trick above, as soon as I delete the last column, the remaining columns expand to fit the already-too-wide width of the entire table (which itself cannot be adjusted), and I'm right back where I started.  :(  

Atlassian needs to get their act together.  This is embarrassingly bad usability, and embarrassingly stupid handling of table formatting.

Like okozina likes this
Like Erik Anderson likes this

And you tried changing the table width from "Responsive" to "Fixed-width"?

Update: I was mistaken, that option is only available in Confluence Server (thank you Tomáš Petržilka). However, I checked Confluence Cloud and this entire issue should be moot anyway, because I was able to adjust the width of the last column by dragging that column's left divider.

hi, this is probably not a solution

as far as I know, it is not possible to set table to fixed width on confluence cloud version

see this answer to the fixed width question


Screenshot 2022-08-19 104332.jpg

Like # people like this

Not an issue anyway.

@HonourNelson hi, thank you for suggestion

I was able to adjust the width of the last column by dragging that column's left divider.

but this approach will also change the size of the previous column, which is not intended..  therefore it does not solve the issue..

If they're asking to make the table wider than the document margins, then at that point, it's not a bug because nothing is allowed to be wider than the document margins, that's what makes them document margins. 


If the request is to adjust the size of the document margins, that question already exists.

@HonourNelson It's not that. It's the fact the last column will sometimes extend past the table's view frame and the user cannot grab the right edge of the last column to resize it so that the whole column comes back into view. It's super annoying. It's kind of the opposite of what you've suggested.

I'd suggest there's another bug here, too, @Tomáš Petržilka. It seems to me the last column is always growing (automatically) just past the table's frame so the right edge is out of view. Unsure what prompts this but it has been happening even before this resizing bug did.


Like Erik Anderson likes this

I can add here that I have the same issue, which I worked around with the previous column method.

However, this has become moot due to the fact that zooming into the doc and back out clobbers my column resizing to the default one used by confluence. As a result, last columns for all tables I have grow past the frame view.

Real lame.

Like # people like this

Aha! I was wondering what caused it. I knew there was *something* I was doing that was making those last columns extend out of view. Thanks.

Hopefully this gets fixed. It's so annoying.

Like Erik Anderson likes this

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events