Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,363,283
Community Members
 
Community Events
168
Community Groups

How do I stop Confluence from automatically changing URLs into link previews

When I type in https://www.example.com/ in confluence, in a few seconds the text changes to "Example" with a link.

I don't want it to convert URLs to text automatically. I don't want Confluence to grab the title of the page and change how the link looks. I want it to show the entire URL that I typed. If I want to change how it looks, I will click the Link button and add text to it.

Please someone tell me how to turn off this new functionality??? I have to keep clicking these links and selecting "Show URL" every time, it's such a pain!

5 answers

On a Mac, let it expand and then hit CMD+z and it will just display the URL

Kalin U Rising Star Apr 26, 2022

Same on Windows: Ctrl+Z should undo the automatic URL conversion.

One workaround I've found is to use the markdown backticks.  It isn't perfect because it formats `https://www.example.com` differently and doesn't hyperlink it at all. 

1 vote

As far as I know this feature is called smart links

Disabling it is not possible yet, but here is the corresponding issue with a couple of workaround ideas. You may want to vote and watch that issue.

This is such a frustrating feature. We encounter it in Service Desk mostly, and it serves no purpose but to confuse communication to customers. Thanks for the link!

Like Daniel Wal likes this

Agreed. Just another "feature" of Confluence that makes my life more difficult. I have to click Ctrl+Z every time I paste a URL into a page. Drives me bonkers.

This is hyper annoying

I paste in spreadsheet as tables , then have to wait for how long "server lost connection" and then all the urls are icons with "home" which does not say that much.

Trying to work around this myself.  Software is trying to be too smart for itself.  Make it an option, please.  Confluence is prefixing my data with "http://".  Totally inappropriate when trying to document DNS records. 

And c'mon, it's not even https...

Like Ryan Dasso likes this
0 votes

I found that I can paste a block of text that includes one or more words (sequence of characters excluding whitespace) that Confluence sees as URLs using "Command+Shift+D".

The full keyboard-only sequence becomes "Command+Shitf+D, Command+V, Tab, Enter", which is a lot more than simply "Command+V", but it's better than having to use the mouse to Unlink potentially dozens or hundreds of words that look like links. Thankfully the dialog that pops up is keyboard friendly.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events