How do I set the "Author" metadata in Confluence 4.x?

In Confluence 3.5 and 3.2, which I used in my last contract, I used the following to set the "Author" metadata:

*Author:* {metadata:Author}[~AJohnstone@biz_name.com]{metadata}

I don't seem to be able to get this to work in 4.0.1, which I am using at home. Any suggestions on how to set this info for use in the checklist-metadata?

E.g.: {checklist-metadata:Author}

Thanks for any help.

2 answers

1 accepted

Hi Allan,

Does this (http://confluence.atlassian.com/display/CONF40/Metadata+Macro) work for you in 4.0.1? I.e. select Insert -> Other Macros and enter a single row table with Author in the first column and the author's details in the second column.

Andrew.

Hmm, what about just Author, rather than Author-Nickname ?

I did try this:

But I get no result in the checklist:

OK, I tried several variants on "Author", and I was able to get the hyperlinked Confluence user name to appear in the table within the metadata macro. It even looked good in the saved page, but in the checklist-metadata table on the parent page, still no entry showed for the page in the "Author" column, and, yes, I did set the column to show the Author metadata; although I must be doing something wrong in the checklist:

Suggestions?

While I am getting daily reminder to close this question, the checklist-metadata still isn't working. If this feature is broken, so be it, but I don't intend to close this question until I get this feature to work or I have been informed that it has a Jira issue opened against it. If I haven't configured that macro correctly, please let me know what I must do. It worked for me in 3.5, but with the new editor I don't know if I have written it up correctly.

This was sort of a two-part question, so I'm marking this first part (setting the Author metadata) to answered as I seem to have that working now. I will open a new question to deal with the second part (how do I get the Author metadata to show up in the checklist-metadata macro?).

BTW, here's a screen capture of the success setting of the metadata... I think.

correct metadata setting... I think

At least, this is pretty much how it appeared in the successful 3.2 and 3.5 setting (with the username hyperlinked, but it still doesn't show up in the checklist).

While it appears that I have set the "Author" metadata in a document, the checklist that I am using to show that information shows nothing in the "Author" column. I have a screen capture of that checklist macro, including the checklist-metadata macro at the bottom of this page. Have I marked this up incorrectly? If not, why is the "Author" column remaining blank?

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Kesha Thillainayagam
Posted Apr 13, 2018 in Confluence

We want to hear how your non-technical teams are using Confluence!

Hi Community! Kesha (kay-sha) from the Confluence marketing team here! Can you share stories with us on how your non-technical (think Marketing, Sales, HR, legal, etc.) teams are using Confluen...

2,486 views 25 10
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you