How can I prevent a link from happening?

Before the wiki "upgrade" which prevents any editing via markup now, I could edit my page to prevent an automatic link from happening. Now I can't, and cannot find out how to do this within the User's Guide. My problem is that I have a line of text with the following:

UTF-8 Regex Test (w/ UTF-8),

And the second instance of UTF-8 appears as if it were an autolink to a Jira issue. I've seen this a couple of times with various forms of XXX-99 text strings, and no longer can fix this to *not* be a link.

Can someone point me in the right direction on how to fix this in the "new and improved" wiki editor? I tried to escape the dash, (UTF\-8) as was once an option in wiki markup, but that just shows me the literal text... not a nice formatting option.

4 answers

1 accepted

This widget could not be displayed.

Put a backslash in front of the hyphen i.e. for instances of UTF-8 you should type out as UTF\-8 to avoid autolink voodoo

This should be the actual accepted-answer because it is correct and resolves the users problem without creating a new problem.

Except that it doesn't work! At least, not in our 7.3.3 on premis instance. 

If I prefix a - with a \ I get \- displayed. No link but still not the text I wanted.

e.g. I have an Epic name with this:

FR\-01 Approve draft consent order with no amendment

If I remove the \ it makes it a link to a withdrawn issue called FR-01 which not only is a link to something irrelevant, it also has a line through it. 

This widget could not be displayed.

This is caused by https://jira.atlassian.com/browse/CONF-27814. I'm pushing to get this fixed at the moment. Feel free to watch/vote/comment on the issue.

This widget could not be displayed.

Hi Susan,

I'm sorry for the trouble with the new editor.

You can prevent the link from happening by including the text in the {noformat} macro.

This is not ideal - it puts a box around the noformat area, but it will stop the link.

This is one of the many usability problems we're going to fix with the Confluence editor in the coming months. Please bear with us!

-Simon

Has this issue been resolved already? How can I prevent such automatic link?

We have several tables with hardware model information like "PJ-123" and Confluence generates JIRA issue links.

Is there any other solution to that ugly {noformat} macro (it's just not bearable in tables)?

How to make the JIRA hyperlink disable .We are using JIRA 6.4.

This widget could not be displayed.

The automatic link creation is extremely annoying for me and the fact that there's nothing (reasonable) I can do in my text to prevent it is just crazy.

Any news about when this will be sorted?

Thanks,
Max

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Monday in Confluence

Why start from scratch? Introducing four new templates for Confluence Cloud

Hi my Community friends!  For those who don't know me, I'm a product marketer on the Confluence Cloud team - nice to meet you! For those of you who do, you know that I've been all up in your Co...

477 views 6 6
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you