Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,466,202
Community Members
 
Community Events
176
Community Groups

How can I fix the migration error "Content is not allowed in prolog"

Hello everyone,

I'm currently testing the migration from Confluence Server to Cloud. We have around 50 Spaces. During the migration about 50% of the spaces fail with the message: "Import to cloud failed. Message: "<GUID>-db.xml" (Line 1): Content is not allowed in prolog." 

ConfluenceMigrationIssue.jpg

Searching about the issue I found out, that the header of the xml file is not in the correct format. But I could not find any Confluence specific results via Google or here.

I could not find the files mentioned on the server or in the database.

I checked with spaces that worked fine, but could not see a difference in the configuration. It also doesn't matter if the space is empty, has only a few documents or has lots of documents. The issue comes up for regardless of Key, Name or Size of the Space.

The server log is also not very helpful, as the only message that shows up there is the error itself. Neither the logs before or after that line give any indication on what produces the problem.

The question I have now is: How do I fix these issues or the header of the xml file?

As a bonus question: How do I find out what causes the "Step failed with an unknown reason"?

2 answers

1 accepted

0 votes
Answer accepted

There seems to be an issue with the Cloud Migration Tool.

https://jira.atlassian.com/browse/MIG-1250

After running the migration multiple times, all Spaces got migrated successfully. I got the error for around 50% of Spaces that I tried to migrate each time.

Until the Migration Tool is fixed you can work around this issue by either

  • Running the migration multiple times and only selecting the spaces that failed migration in the last run or
  • export the spaces in the server instance and importing them in the cloud instance manually
0 votes
Trudy Claspill Community Leader Dec 22, 2022

Hello @Fabian Schmitz 

Welcome to the Atlassian community.

Have you already opened a case with Atlassian Support to get support with your migration? Migration is one of the categories available when opening a support case.

https://support.atlassian.com/contact/#/

Hello @Trudy Claspill ,

as our support subscription expired quite some time ago, I didn't even think about opening a support ticket. I will do that now and see what comes from that.

Thank you for the tip.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events