How can I connect a new Confluence Ubuntu server to an existing database without creating a new database

Currently I have Confluence running in windows server with Microsoft SQL 2008 database, and i have built a new ubuntu server with Confluence installed. Confluence Home Directory from windows has been copied to Ubuntu, and confluence.cfg.xml file has been updated.

Finally I got error message in browser below:

-------------------error message starts------------------

logo System Error

A system error has occurred — our apologies!

For immediate troubleshooting, consult our knowledge base for a solution.

If you would like to receive support from Atlassian's support team, ask your Confluence administrator to create a support issue on Atlassian's support system with the following information:

  1. a description of your problem and what you were doing at the time it occurred
  2. a copy of the error and system information found below
  3. a copy of the application logs (if possible).

Your Confluence administrator can use the support request form to create a support ticket which will include this information.

We will respond as promptly as possible.
Thank you!

Return to site homepage…

The SystemInformationService could not be retrieved from the container. Therefore very limited information is available in this error report.
The SystemInformationService could not be retrieved due to the following error: java.lang.NullPointerException

Cause

com.atlassian.util.concurrent.LazyReference$InitializationException: java.lang.NullPointerException
at com.atlassian.util.concurrent.LazyReference.getInterruptibly(LazyReference.java:152)

caused by: java.lang.NullPointerException
at com.atlassian.spring.container.ContainerManager.getComponent(ContainerManager.java:33)

Stack Trace:[hide]

com.atlassian.util.concurrent.LazyReference$InitializationException: java.lang.NullPointerException
	at com.atlassian.util.concurrent.LazyReference.getInterruptibly(LazyReference.java:152)
	at com.atlassian.util.concurrent.LazyReference.get(LazyReference.java:115)
	at com.atlassian.confluence.web.filter.LanguageExtractionFilter.getLocaleManager(LanguageExtractionFilter.java:63)
	at com.atlassian.confluence.web.filter.LanguageExtractionFilter.doFilter(LanguageExtractionFilter.java:48)
	at com.atlassian.core.filters.AbstractHttpFilter.doFilter(AbstractHttpFilter.java:31)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at com.atlassian.confluence.util.RequestCacheThreadLocalFilter.doFilter(RequestCacheThreadLocalFilter.java:25)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at com.atlassian.core.filters.HeaderSanitisingFilter.doFilter(HeaderSanitisingFilter.java:44)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at com.atlassian.confluence.servlet.FourOhFourErrorLoggingFilter.doFilter(FourOhFourErrorLoggingFilter.java:65)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
	at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
	at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
	at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:298)
	at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:859)
	at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:588)
	at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:489)
	at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.NullPointerException
	at com.atlassian.spring.container.ContainerManager.getComponent(ContainerManager.java:33)
	at com.atlassian.confluence.util.LazyComponentReference$Accessor.get(LazyComponentReference.java:44)
	at com.atlassian.util.concurrent.Lazy$Strong.create(Lazy.java:88)
	at com.atlassian.util.concurrent.LazyReference$Sync.run(LazyReference.java:326)
	at com.atlassian.util.concurrent.LazyReference.getInterruptibly(LazyReference.java:146)
	... 25 more

        

Referer URL

http://192.168.69.106:8090/

-------------------error message ends-----------------------

Ubuntu version: 12.04

Java version: OpenJDK 1.6.0 come with Ubuntu

Confluence version: 4.2.3 64bit

Appreciate any advice!!!!!

4 answers

1 accepted

This definitely is a problem that is specific to the mix of Confluence with Ubuntu 12.04 (or 12.04.1 for that matter).

I just went through the process of upgrading our ubuntu release from Natty (11.04) up to 12.04.1. To get to 12.04 from 11.04 it is necessary to do the do-release-upgrade twice. First you have to upgrade to 11.10, and then when you run it the second time you can go up to 12.04.1.

I tested our confluence / Jira environment after upgrading to 11.10 and it worked fine. Then after upgrading to 12.04.1 I'm getting the exact same error messages as described above.

I don't have an answer as to the issue, but I spent enough time on this to confidently state that the problem rests with some change that came with ubuntu between 11.10 and 12.04.

Are you sure this is a Database connection issue?

From the logs, i cant get a clear picture. but here is the step to trouble shoot this issue if its realted to database being located on a different machine

Check and see if your MSSQL server allows remote connections, for security measures they default to localhost only unless a DBA steps in and allows remote connections

These links might not be for the same version os MS SQL you are using but concepts apply

http://www.linglom.com/2009/03/28/enable-remote-connection-on-sql-server-2008-express/

http://blogs.msdn.com/b/walzenbach/archive/2010/04/14/how-to-enable-remote-connections-in-sql-server-2008.aspx

If you have X installed on ubuntu you can check using clients like http://squirrel-sql.sourceforge.net/

or telnet hostname/ip portNumber

If you are able to connect then your confluence instance should be able to connect to

let us know how it goes

Thank you! Parthis,

My Microsoft SQL 2008 remote connection is set up. firewall rule exception is set up as well. I even use the testdatabase.jsp from Atlassian website to test MS SQL connection. It shows that remote connection, authentication, and MS SQL driver are all working fine.

Is it the problem of JAVA?

I use the pre-installed OpenJDK 1.6.0 in Ubuntu 12.04. JAVA_HOME is set as well.

I have tried the new databse on MS-SQL server and new installation of Ubuntu. Then, restore the confluence backup file to my Ubuntu Confluence. All data have been inserted to my new database successfully.

What i confuse is why i can not connect my new Ubuntu Confluence to an existing MS-SQL database, so that i do not need to backup and restore confluence file.

Maybe i need to fix it as what u suggest.



That rules out database connectivity issues. one more thing to check.

Check the "ubuntu user" which you use to starts up your application has all the permissions to the application directory as well as the home directory.

you get unexpected errors which does not give you a clear picture if the user who starts up the application does not have read/write permissions to all these directories.

if this fails do a test,

Start with a new installation and a new database on your MS-SQL server try and set this new installation up, if this goes well then i suspect your installation might be corrupt.

Thomas Schlegel Community Champion May 24, 2012

did you check the atlassian-confluence.log located in confluence-home/logs ?


We are having the same issue, since upgrading to Ubuntu 12.04. We have double-checked database connections, passwords etc and nothing seems to help.

Hi, picked up that you're using OpenJDK? That JVM isn't supported and does cause problems, have you tried with Oracle 1.6.0.26 or 1.7 https://confluence.atlassian.com/display/DOC/Supported+Platforms ? Might not be the issue here, but I've seen similar DB looking errors when using an unsupported JVM. Andrew.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Monday in Confluence

Calling all marketing teams who use Confluence - we want to hear from you!

Hi Community! me again 🙂 If you’re a marketing team using Confluence, we want to hear your story! How did you start using Confluence? What are your use cases? What have been some of the benefits?...

195 views 3 3
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you