It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

How can I clear the content of cells in a table?

Eric Ladouceur Jan 14, 2015

Hi all,

  I have a Confluence table and I would like to delete the content of a handful of cells.  I can enter the Edit mode, then I can select the cells I would like to clear, but when I press the delete key, entire rows are being deleted instead of the selected cells. 

Lets say I have a 5x5 table and I select cells B4, B5, C4, C5.  I see those cells being highlighted, but when I release the mouse to look at my selection, I see that Firefox is also selecting the text in cells B4, B5, C1, C2, C3, C4, C5...  So when I press the delete key, all cells in row C get deleted.

I am running Confluence 5.6.3 on Firefox 25.0.

5 answers

1 vote
Peter White Feb 10, 2018

This is a pretty basic function Confluence should be able to offer in their tables :(

Karthik Chembu May 16, 2018

Really Bad Confluence have lot of limitations. Even for this small functionality too.

1 vote
karrezza Jan 23, 2019

This is beyond embarrassing.  

I use the tables to log test results, and you have to delete EVERY SINGLE CELL manually.

Date command object doesn't delete but char by char most the time., so its backspace about 10 times to clear a date. you can't double click in a cell and get it to highlight it all. It stops working. (CHROME). 

You do CTRL -A it highlights the entire page.  This is AWFUL functionality. 

Peter White Jan 23, 2019

I find that when I highlight several cells it will only visibly highlight the first one though it will delete the remaining cells "invisibly" highlighted. Trouble is that you can't see what is being highlighted (exception of first cell) so its real guess work!!  

I resort to the more onerous approach by importing Excel sheets for others to review on more complex arrangements.

As you say it is an AWFUL functionality with still no improvements.

C'mon Atlassian!!

Like karrezza likes this
karrezza Jan 23, 2019

My "work around"  is I created templates of my test cases pages, and tell my testers to "make a copy" and modify the title to reflect the date of their test pass.. but dang, how tedious. 

Peter White Jan 23, 2019

FYI, an email I received :

"We have had this reported previously where CONFCLOUD-24245: Delete Table Cell. However, as mentioned by our Product management team in the comments, this feature will not be implemented in the near future.

The workaround for this is to merge dangling cells into the left cell.

Now, i understand that this feature request has been quite some time.
What i am planning to do is to raise this with our Product management team again to see whats their intake on deleting cell tables currently.

Please allow us some time to review this further.

Thanks,"

0 votes

Hello Eric, this is reproduceable in other browsers as well, and was documented a while ago in this issue ticket. I agree that there should be a better manner to remove contents from a table, turns out it appears not have a straight forward resolution at this time - only the workaround of removing each cell content with double click + delete.

 

Joyce Bailey Aug 08, 2018

@Guilherme Nedel  Still no solution for this?

Joyce Bailey Aug 08, 2018

@Guilherme Nedel nevermind, highlighted the data worked!

karrezza Jan 23, 2019

Did you just highlight for one cell?  Your "what worked" isn't clear. The issue is a "Wont' Fix"   Which is terrible for large cells.

0 votes
Matt Smith Aug 16, 2018

an easier way is to use the merge cells function to merge all cells in a select column or row, then just highlight text all in one cell hit delete, then split cells again. 

 

However in 2018 i expect a paid for text content editor like Confluence to have such basic functionality. The only value in Confluence is that it links easier with other Atlassian Products with a little integration. However using Google sheets and linking to a JIRA ticket for example is a better alternative for me at this point. Depends on how deeply you use Confluence i suppose.

Peter White Aug 16, 2018

Thanks for the tip.

Again this seems excessive to simply delete numerous rows/columns of data or selected data.

Atlassian should either offer an enhanced functionality (albeit still basic) or don't.

0 votes
Den Ramos I'm New Here Feb 11, 2019

There's a workaround for this. Just open up a spreadsheet program, copy and paste the same number of empty columns / rows you want and paste it in to override the cell range.

Suggest an answer

Log in or Sign up to answer
This widget could not be displayed.
This widget could not be displayed.
Community showcase
Published in Confluence

Confluence CVEs and common questions

Two vulnerabilities have been published for Confluence Server and Data Center recently: March 20, 2019 CVE-2019-3395 / CVE-2019-3396 April 17, 2019 CVE-2019-3398 The goal of this article is...

909 views 0 19
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you