How Do I Disable Collaborative Editing in Confluence 6.1.3?

I have to say, at this point I am not impressed with the product.  The install process is gruling, there is not much in the way of guides beyond steps like (Set up a database), and I have encountered issues on almost every single step.  Up to this point I have been able to figure them out. 

I have installed Confluence Server, imported my content from my Cloud instance, and set up SSL.  I can browse Confluence just fine but if I click Create or Edit the page just hangs.  It does not error out, the wheel at the edit button just spins.  I foung that if I disable the firewall, I get to the Edit page but get an error in the Browser about how it is taking longer than normal to load.  I think this has to do with Synchrony operating on port 8091.   

As I understand, there are known issues with Collaborative Editting and SSL.  I do not need Collaborative Editing and would like to disable it but the settings do not show up where they are supposed to in the General Configuration page.  I am running 6.1.3.  Here is the error from the catalina.out log. 

 Thanks for any help you can provide. 

04-May-2017 16:59:08.844 WARNING [ContainerBackgroundProcessor[StandardEngine[Standalone]]] org.apache.catalina.valves.StuckThreadDetectionValve.notifyStuckThreadDetected Thread "http-nio-8443-exec-14" (id=178) has been active for 69,489 milliseconds (since 5/4/17 4:57 PM) to serve the same request for https://[redacted]:8443/pages/createpage.action?spaceKey=[redacted]&fromPageId=34335&src=quick-create and may be stuck (configured threshold for this StuckThreadDetectionValve is 60 seconds). There is/are 3 thread(s) in total that are monitored by this Valve and may be stuck.
java.lang.Throwable
at java.net.PlainSocketImpl.socketConnect(Native Method)
at {followed by a ton of Java errors}

2 answers

0 vote
Steven Behnke Community Champion May 04, 2017

If you access this over a non-ssl port, does the editor work then? You also haven't told us what you're using for OS or if you're using a Proxy so it'd be difficult to offer advice at this time.

Sorry about that, thanks for your assistance.

Running Ubuntu 16.04 with PostgreSQL as the batabase. 

For the SSL I followed the steps here: https://confluence.atlassian.com/doc/running-confluence-over-ssl-or-https-161203.html

Disabling the SSL redirect and accessing the site over HTTP yeilds the same result.  Tried in Chrome and Edge. 

I also wanted to test disabling Collaborative Editing to see if that works (as I don't need it) but perhaps that is no longer possible in 6.1.3.

 

0 vote

It is a good test to disable the collaborative editing - the admin flag for turning it off it is still there in 6.1

Nic, Thanks. 

I looked harder and finally found the config option.  It is not where the documentation says it is, it is under Gear > Add-Ons > System > Confluence Collaborative Editor Plugin.


Good news, disabling this plugin solved the problem.  Next trick is to figure out how to make collaborative editing work with SSL, but this is not a requiments for my installs so I am good to go for now.  Thanks!

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Tuesday in Confluence

We want to see the templates you've created in Confluence!

Hi Community, Jessica here from the Confluence Product Marketing team!  July’s community challenge is all about sharing pictures  — and as an extension of our first post on what ...

426 views 18 9
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you