Home page restrictions are not removed

Accidentally a user of a space restricted the viewing of the space's home page to a few people only. Therefore all the other people could not access the home page. She tried to remove the restrictions and we tried to remove them by using the Restricted Pages list in the administration, too.

Unfortunately there are a lot of pages in this space. Therefore removing the restrictions of the home page took very very long. Additionally the user - who made the fault - tried to remove the restrictions multiple times. As it took so long, she pressed Cancel every time. I am not sure if some of the processes perhaps are still running.

The current situation is as follows:

The Restricted Pages section does not show any restrictions for the home page any more. But nobody is able to access the home page currently. We see only You cannot view this page.

What can we do to access the pages of the space again?

2 answers

1 accepted

Hi Simone,

you cloud export the whole space as XML - then do the following steps:

  • edit the xml-file inside the export.zip and remove restrictions (if they are still there)
  • delete the space in Confluence
  • import the modified export

You can also import the backup into an test-environment before deleting. So you could check if your modifications are working.

mfg
Michael

Hi Michael,

I edited the entities.xml file and removed the permissions for the home page. This was an entry in the page object itself

<collection name="contentPermissionSets" class="java.util.Collection"><element class="ContentPermissionSet" package="com.atlassian.confluence.security"><id name="id">17203237</id>
</element>
</collection>

and the contentPermissionSet object which seemed to be empty:

<object class="ContentPermissionSet" package="com.atlassian.confluence.security">
<id name="id">17203237</id>
<property name="type"><![CDATA[View]]></property>
<property name="owningContent" class="Page" package="com.atlassian.confluence.pages"><id name="id">9011284</id>
</property>
<property name="creationDate">2013-02-26 13:19:45.438</property>
<property name="lastModificationDate">2013-02-26 13:38:33.930</property>
</object>

The imported space works correctly now.

Thank you very much for your support,

Simone

Hello,

first let me know if you can log into Confluence as admin, if so double check if restrictions were removed and then go to Browse > Confluence Admin > Cache statistics and flush all.

Actually I suspect that it was caused due some malfunction form the database.

Also, if you're not able to log as Admin you can create a new admin account and then copy the contents of that page, then removed that malfunction page and finally create the page again.

This doc informs how to create a new admin account:

https://confluence.atlassian.com/display/DOC/Restoring+Passwords+To+Recover+Admin+User+Rights

I believe these workarounds may help you.

Hi Bernardo,

thanks a lot for your answer. The access to Confluence as an admin is no problem and all the other spaces are doing fine. Only the one space where the restrictions have been, cannot be accessed. The "Restricted Pages" section show no more restrictions for the home page, but nobody is allowed to view it :-(

Unfortunately the flush of the caches did not help.

Thanks,
Simone

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Jul 10, 2018 in Confluence

We want to see the templates you've created in Confluence!

Hi Community, Jessica here from the Confluence Product Marketing team!  July’s community challenge is all about sharing pictures  — and as an extension of our first post on what ...

995 views 23 13
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you