Help in running a macro.

Hi ,

I need to run the CLI plugin and fetch the confluence details from UI , refered the CLI plugin , https://bobswift.atlassian.net/wiki/display/CCLI/Documentatio

Could any one please help in understanding how to run the plugin , I create a macro but didn get how to invoke same.

Thanks,

Aravind

5 answers

1 accepted

This widget could not be displayed.

I have actually replaced the username/pwd , Also replaced the URL properly .

-=-

unable to log in to server: http://myIP/rpc/soap-axis/confluenceservice-v1 with user: XXXX.
Cause: (404)Not Found

-=-=

Any idea why the "404 not found error " is coming .When i launch http://myIP/rpc/soap-axis/confluenceservice-v1 in Browser same error is seen

Do i have to run any service in confluence server .

  1. Make sure the server address is correct :)
  2. Yes, Confluence must be configured to accept remote requests. By default, it is usually on, but you may have turned it off. Go to Confluence administration -> General Configuration and make sure Remote API is checked.
This widget could not be displayed.

Iam trying to rad and update the confluence details using CLI .,

Below are the approach tried,

1.Refered the below link

https://bobswift.atlassian.net/wiki/display/CCLI/CLI+Macro.But i am not getting how to call this whether we have to wrirte a Macro or some other means , If macro how to run it .

2.As per mentioned in the link http://ffeathers.wordpress.com/2011/10/20/confluence-cli-for-bulk-actions-like-deleting-or-publishing-pages/

tried downloading the CLI ( atlassian-cli-3.4.0 )in the desktop and ran the command ./atlassian.sh confluence --action getServerInfo

it gave below error

Unable to log in to server: http://myIP:Port/rpc/soap-axis/confluenceservice-v1 with user: confluence.
Cause: (404)Not Found

Firing http://myIP:Port/rpc/soap-axis/confluenceservice-v1 in Browser also gives same result

Confluence version : 4.3.2

Please let me know if more details required also correct if my understanding is wrong.

Ok, that's making more sense - there are two questions here.

1) The macro enables you to run things that will be executed by the CLI and the results returned as part of the text of the page you put the macro on to.

My recommendation here is to forget this until you've got the CLI to do what you want. It's powerful and helpful, but worth understanding what it's doing from the ground up

2) The CLI runs *outside* your Atlassian products. You're not telling it what to connect to, so it's using a default, which is wrong, so it's failing (The default is intended to try to show you an error message that makes it clear what you're missing)

Try

/atlassian.sh confluence --server http://yourconfluenceurl.yourorganisation --action getServerInfo

Agree with Nick, always start with something simple until you get a grasp of the tool and what it provides including how to configure it. Installation and Use tells you how to customize the bat/sh file to make it easier to use.

What is the difference between CLI clients and CLI plugins? will help you understand the differences in the tools and capabilities.

This widget could not be displayed.

Could you clarify this a little?

The CLI is a command line interface for interacting with Confluence

A macro is something you add to a page to do something clever in that page.

The two things are not really related, other than they both get used in Confluence, so could you explain what the question is? Are you stuck on using the CLI? Or with macros? Or are you trying to do somthing sneaky with both?

This widget could not be displayed.

Tried below

/atlassian.sh confluence --server http://yourconfluenceurl.yourorganisation --action getServerInfo

getting the Error: Parameter 'server' cannot be declared more than once.


Looks like this error is coming as the params are already specied in atlassain .sh

-=-

if [ "$application" = "confluence" ]; then
string="confluence-cli-3.4.0.jar --server http://myIP/ --user $user --password $password"
-=-=


My apologies, I wasn't looking at atlassian.sh, I was looking at confluence.sh, so I missed the point that atlassian.sh already specifies a --server string

However, it does clearly say "edit this and use your server's url" in there, and the error is clearly showing that you're using the default. Could you try swapping the default myIP for your actual Confluence url?

This widget could not be displayed.

Thanks for your suggestions ,

I made sure that the IP is proper by firing it in browser and also Remote API is checked in confluence UI .

Could you please let me know if there is any other setting missing , which is causing 404 error when i fire http://myIP/rpc/soap-axis/confluenceservice-v1 from browser.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Monday in Confluence

Why start from scratch? Introducing four new templates for Confluence Cloud

Hi my Community friends!  For those who don't know me, I'm a product marketer on the Confluence Cloud team - nice to meet you! For those of you who do, you know that I've been all up in your Co...

317 views 2 5
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you