HTTP Error on uploading files

I am currently unable to attach any files to any pages. Every time I am presented with an HTTP Error, whether it is dragging and dropping or selecting a file from my filesystem.

I have so far: restarted Confluence, restarted the server, verified Confluence's max filesize, verified my php's 'upload_max_filesize' and 'post_max_size', upgraded confluence.
On top of this nothing shows up in Confluence's logs (in Diagnostic mode).

A potentially related issue is that I am unable to update or install plugins from the marketplace (or modify licenses), but I am able to upload and uninstall them.

Any help would be appreciated. Thanks.

1 answer

This widget could not be displayed.
Ann Worley Atlassian Team Aug 07, 2017

Are you using NGINX or any other proxy? I found this similar issue that was solved at the proxy: Getting HTTP Error, when uploading a file

If it's not the proxy, please post a screen shot of the HTTP error (use the little camera icon :))

I am using Apache's mod_proxy. Everything was working for a few weeks before it stopped, and nothing proxy related was changed. I'm happy to play around with it, but I'm not sure where to start.

 

http_error.png

Ann Worley Atlassian Team Aug 09, 2017

Let's identify or eliminate the proxy as the culprit by connecting directly from your workstation as described in:

How do I bypass a proxy to test network connectivity

If you get the same error we can go from there.

Thanks Ann, this issue somehow resolved itself, which is disconcerting. However my users seem to be able to upload images so I think for now this is (somewhat) resolved. 

While we're at it, I seem to be unable to log into this tunnel or connecting to the server directly through confluence's port) (ie myserver.com:<port>/confluence). Any suggestions on resolving this?

Ann Worley Atlassian Team Aug 09, 2017

When it says: "After setting up the tunnel browse to http://hostname:<local port> and the local port will be forwarded to the Confluence port on the remote host." it means "After setting up the tunnel browse to http://workstation's_hostname:<local port> and the local port will be forwarded to the Confluence port on the remote host.

The proxy will usually not allow you to connect to http://server:port directly.

I am able to access my website though both localhost:<local-port> and myserver.com:<remote-port>, but I am unable to log into either on various browsers and computers

Ann Worley Atlassian Team Aug 09, 2017

Stefan, you cannot log into Confluence at all? What error do you see when you try to log in? When did this start?

I am able to access my website though both localhost:<local-port> and myserver.com:<remote-port>, but I am unable to login when using these ports. 

I am able to login normally through the proxy.

Ann Worley Atlassian Team Aug 09, 2017

Please let me know what error you see when you cannot log in. Is it an error indicating wrong username or pasword or is it "not permitted"?

For more clues, please search the <confluence_home>/logs/atlassian-confluence.log for errors that contain your username.
Note: The <confluence_home> directory is the path defined in the following file: <confluence_install>/confluence/WEB-INF/classes/confluence-init.properties

Does your company use any external SSO or other user management layer between the clients and Confluence or do you log into the plain vanilla login screen?

Unfortunately there are no errors getting displayed and we let confluence manage its user directory.

The relevant lines form the log file are:

2017-08-09 15:42:56,238 DEBUG [http-nio-8090-exec-3] [atlassian.seraph.filter.BaseLoginFilter] doFilter doFilter : ____ Attempting login for : '/dologin.action'
2017-08-09 15:42:56,239 DEBUG [http-nio-8090-exec-3] [atlassian.seraph.filter.PasswordBasedLoginFilter] login login : 'user' and password provided - remember me : false - attempting login request
2017-08-09 15:42:56,241 DEBUG [http-nio-8090-exec-3] [atlassian.seraph.filter.PasswordBasedLoginFilter] runAuthentication runAuthentication : 'user' does not require elevated security check. Attempting authentication...
2017-08-09 15:42:56,265 INFO [http-nio-8090-exec-3] [atlassian.confluence.cache.DeferredOperationsCache] sync Synchronising deferred operations (0 putIfAbsent, 0 put, 1 remove, 0 get) to cache [com.atlassian.confluence.user.crowd.CachedCrowdUserDao.ATTRIBUTE_CACHE]
2017-08-09 15:42:56,266 DEBUG [http-nio-8090-exec-3] [atlassian.seraph.auth.DefaultAuthenticator] login login : 'user' has been authenticated
2017-08-09 15:42:56,267 DEBUG [http-nio-8090-exec-3] [atlassian.seraph.auth.DefaultAuthenticator] authoriseUserAndEstablishSession authoriseUser : 'user' can login according to the RoleMapper
2017-08-09 15:42:56,268 DEBUG [http-nio-8090-exec-3] [atlassian.seraph.filter.PasswordBasedLoginFilter] runAuthentication runAuthentication : 'user' was successfully authenticated
2017-08-09 15:42:56,270 DEBUG [http-nio-8090-exec-3] [atlassian.seraph.filter.BaseLoginFilter] doFilter doFilter : Login completed for 'null' - os_authstatus = 'success'
2017-08-09 15:42:56,270 DEBUG [http-nio-8090-exec-3] [atlassian.seraph.filter.BaseLoginFilter] redirectToOriginalDestination redirectToOriginalDestination : Login redirect to: /confluence/

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted yesterday in Confluence

Why start from scratch? Introducing four new templates for Confluence Cloud

Hi my Community friends!  For those who don't know me, I'm a product marketer on the Confluence Cloud team - nice to meet you! For those of you who do, you know that I've been all up in your Co...

155 views 2 4
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you