HTTP 500 on localhost:8090/bootstrap/selectsetupstep.action

Hello,

I am trying to install confluence but whenever I start the server and navigate to the above URI I get;

HTTP Status 500 - Invocation of method 'getUserLocaleDefaultDatePattern' in class com.atlassian.confluence.setup.actions.SelectSetupStepAction threw exception java.lang.NullPointerException at /decorators/includes/header.vm[line 51, column 47]

I have already tried restarting the server but no luck.

Any help/advice would be much appreciated.

Thank you.

4 answers

1 accepted

Hi Felipe and Saleh,

So I made it work now and I have finally navigated to the installation page.

What i did is;

- Setup a clean confluence directory and a confluence-home dir

- change the listen ports

- set confluence-home config from scratch

And it worked.

Im not sure why this happened but this is how i made it work.

Thanks for your help again.

Cheers,

Peter

Hi Peter,

Can you please upload the contents of your <install folder>/logs/catalina.out and <data folder>/logs/atlassian-confluence.log

Best regards,

Felipe Alencastro

Hello Felipe and Saleh,

Thank you for your quick response.

Please find the logs attached.

catalina.out: (catalina.out.log)

atlassian-confluence.log: (atlassian-confluence.log)

I have also tried to install Confluence with full permissions but i get the same error.

Also, please note that on the same machine I am running Jira and Stash with no errors/issues.

Thank you,

Peter

Hi Peter,

Please ensure that the user that run Confluence has full permissions (Read, Write, Execute) in <Confluence-Home> and <Confluence-Install> directories.

However, if your user has full permissions for further investigation you need to refer to your log files that mentioned by Felipe.

Cheers,

Saleh

Hello Peter,

I've looked through your catalina.out file and I found following error:

SEVERE: Failed to initialize end point associated with ProtocolHandler ["http-bio-8090"]
java.net.BindException: Address already in use &lt;null&gt;:8090
	at org.apache.tomcat.util.net.JIoEndpoint.bind(JIoEndpoint.java:407)
	at org.apache.tomcat.util.net.AbstractEndpoint.init(AbstractEndpoint.java:623)
	at org.apache.coyote.AbstractProtocol.init(AbstractProtocol.java:434)
	at org.apache.coyote.http11.AbstractHttp11JsseProtocol.init(AbstractHttp11JsseProtocol.java:119)
	at org.apache.catalina.connector.Connector.initInternal(Connector.java:981)
	at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:102)
	at org.apache.catalina.core.StandardService.initInternal(StandardService.java:559)
	at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:102)
	at org.apache.catalina.core.StandardServer.initInternal(StandardServer.java:814)
	at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:102)
	at org.apache.catalina.startup.Catalina.load(Catalina.java:640)
	at org.apache.catalina.startup.Catalina.load(Catalina.java:665)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:606)
	at org.apache.catalina.startup.Bootstrap.load(Bootstrap.java:281)
	at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:455)
Caused by: java.net.BindException: Address already in use
	at java.net.PlainSocketImpl.socketBind(Native Method)
	at java.net.AbstractPlainSocketImpl.bind(AbstractPlainSocketImpl.java:376)
	at java.net.ServerSocket.bind(ServerSocket.java:376)
	at java.net.ServerSocket.&lt;init&gt;(ServerSocket.java:237)
	at java.net.ServerSocket.&lt;init&gt;(ServerSocket.java:181)
	at org.apache.tomcat.util.net.DefaultServerSocketFactory.createSocket(DefaultServerSocketFactory.java:49)
	at org.apache.tomcat.util.net.JIoEndpoint.bind(JIoEndpoint.java:394)
	... 17 more

Above stacktrace shows that assigned port number being used by another service. Please ensure that the port number you're using for your instance is not occupied by the other application.

However, you can refer to following documentation to see how to change your Confluence port number:

I found following knowledge base also, you can check the cause and resolution of this issue in following knowledge base article:

Cheers,

Saleh

Hello Saleh,

Thank you for your help.

I have followed all the steps you provided me with, and I have changed the listen port as described in the documentation but I still get the same error.

I also do not get the above port error anymore (in catalina.out) but a different one which can be found in the attached folder;

: (catalina.out.log)

Furthemore, I have executed netstat -an but it did not gave back useful information. So, it seems that the :8090 port is free.

Not sure how to proceed, so any advice is appreciated.

Thank you,

Peter

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Kesha Thillainayagam
Posted Apr 13, 2018 in Confluence

We want to hear how your non-technical teams are using Confluence!

Hi Community! Kesha (kay-sha) from the Confluence marketing team here! Can you share stories with us on how your non-technical (think Marketing, Sales, HR, legal, etc.) teams are using Confluen...

1,232 views 23 10
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you