1. Problem:
I'm using the Confluence On Premises SAML App, okta would send https://xxxxxx.okta.com/app/confluence_onprem/yyyyyyyyyyyyyyyyy/sso/saml
and it goes to https://zzzzzzz.net/index.action fine but missing page body while the header and footer shows up correctly. when I use https://zzzzzzz.net/index.action directly or click on the banner, which loads https://zzzzzzz.net/index.action, then the then everything loads properly.
2. debugging:
I'm also seeing below when debugging through inspect, that 405 error on index.action
Request URL: https://zzzzzz.net//index.action
Request Method: POST
Status Code: 405
Remote Address: 10.1x.1x.3x:443
Referrer Policy: no-referrer-when-downgrade
3. Setup:
our confluence is behind HA proxy and user get to it through okta.
HA proxy -> okta -> confluence -> brikit
4. Summary:
What really weird is that when I go to the https://zzzzzzz.net/index.action through https://xxxxxx.okta.com/app/confluence_onprem/yyyyyyyyyyyyyyyyy/sso/saml , it loads everything but the body but if I get to the https://zzzzzzz.net/index.action directly, it works fine.
5. Questions:
any ideas what might be wrong?
Is there a way I can refresh the body or the entire thing through redirection?
Hi Thomas,
Welcome to Atlassian Community! It's nice to meet you.
According to Okta's troubleshooting guide, Status Code 405 means:
The Access Gateway has detected an anomaly in user access to the
<Requested Application>
.Possible Cause
The Access Gateway will return this status code when it detects a possible issue with session integrity to prevent sessions from being hijacked. This can also happen when a user switches networks with an active session in place.
The recommended resolution is to ensure that the user isn't changing networks during the active session, and to try creating a new session. I don't think that necessarily would solve your issue here.
In this case, you can raise a Support Ticket with Okta and they can try and help you with this issue. You can follow-up with us when you're able to resolve the issue in case other users are experiencing the same issue.
Regards,
Shannon
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