Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,363,868
Community Members
 
Community Events
168
Community Groups

Gliffy connectors not gluing to shapes

I created 2 basic workflow shapes and dragged a connector between them. What I expect is that the connector will latch to both shapes and if I move a shape the connector will follow. Lately this often doesn't work - one end of the connector has no connection capability, as if it was just a normal line. If I move the shape the connector doesn't move. It's not a case of an unglued connection - that end of the line has no gluing function even if I drop it over the shape again. This started happening in the last week or so. Any ideas?

5 answers

Quick work around from my part (just found out), which worked for me (for now): In the editor, when the connectors are showing the described symptoms, I pressed F5 (refresh) and chose 'refresh' in the dialogue popping up. It refreshed the gliffy, but somehow also reset the editor somehow. Now the connectors are working as normal!

Hope this helps! 

Worked for me too

Copying and old connector from your drawing, seems to not introduce the problem

Hi there! 

I am experiencing the same problem! The start point of the connector does not get any control (circle) after creating it. It is still connected to the shape I created it from, but it is not being able to be reconnected. When moving the start point of the connector, the whole line moves, as you would expect dragging the line itself (and not a en-point control). 

Really looking forward to a solution!

 

//Mathijs

Hey Matt!

I haven't heard anything about a bug along those lines. (Pun intended!)

I also just double-checked and I'm not seeing any open tickets about issues with connectors in our server deployment. Do you mind emailing the support team so that they can get all the details we need to replicate and get this sorted out for you? That'll be support@gliffy.com.

Thanks for your help!

Samie

0 votes

Is there any update on a fix for this bug? I am seeing the same issue, though on an internal server installation of Confluence, so wondering if we need to update

Hi Joe!

I would reach out to our support team at support@gliffy.com to find out which version includes a fix for this!

Samie

Thanks Samie

I've just had a user complaining of a similar problem. In their case they would tweak the diagram to have connectors in the right places and when they save back to confluence the changes are lost and the connectors seem to remain unmoved - sometimes showing diagonal lines and looking a real mess. We are on the latest version.

Hey Andy! That's obnoxious — I'm really sorry that's happening. Would you mind reaching out to the support team as well? Their email is support@gliffy.com.

It sounds like your issue is a little bit different (happening in the diagram viewer in Confluence, not in the editor itself) so I want to make sure they get all the details.

Thank you SO much for your help!

Thanks for commenting, I have reached out to support to see if they can reproduce this.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events