Getting error:"Unable to communicate with server. Saving is not possible at the moment."in

I am getting the following errors when using Chrome and FF but no errors using IE.

Unable to communicate with Server. Saving is not possible at the moment.

The editor didn't load this time. The connection timed out.

Turned off Collaborative Editing and no errors using any browser...can edit pages in this mode.

 

 

2 answers

1 accepted

0 votes
Accepted answer
Ann Worley Atlassian Team Jan 02, 2018

I think it is significant that you don't get the error in IE. That exact error can be generated in Chrome if the Last Pass extension is enabled: Unable to save Confluence page in Chrome (caused by LastPass extension)

Please try Firefox in safe mode and Chrome in incognito mode (right click on the Chrome icon and choose New Incognito Window) to see if the error can be eliminated by disabling browser extensions.

I look forward to hearing the results.

Tried both Chrome and Firefox as you requested...still fails with same errors.

Using iis 8.5 on 2012 R2 as reverse proxy and verified websocket is installed.

Ann Worley Atlassian Team Jan 02, 2018

Thanks for those proxy details. This Stack Overflow post describes some interesting behavior with Websockets, IIS and Chrome: Websockets reverse proxy in IIS 8

It mentions the same gotcha as our doc:

...IIS 8.0 does not support the Sec-WebSockets-Extension permessage-deflate header

The document continues with instructions for adding a system property to fix this: 

As IIS 8.0 does not support the Sec-WebSockets-Extension permessage-deflate header, you will also need to add the following to your <install-path>/bin/setenv.bat or setenv.sh if you start Confluence via script, or by command line or registry if you are running as a Windows service. See Configuring System Properties.

CATALINA_OPTS=-Dorg.apache.tomcat.websocket.DISABLE_BUILTIN_EXTENSIONS=true %CA

It is also important to make sure proxyName proxyPort and scheme are set in the Confluence server.xml file as described in  3.2. Configure other Atlassian applications web server (Tomcat)
 

I got it working...thank you!

I had to add the above CATALINA_OPTS and changed my Rewrite rules in the web.config to match the Sample web.config for Synchrony in the "Proxying Atlassian server applications with Microsoft Internet Information Services (IIS)" doc.

Ann Worley Atlassian Team Jan 11, 2018

That's great news, thanks for following up on behalf of the next person who faces that issue.

@Ann Worley

Hi,

I have the exact same problem. I tried the solution you mentioned above with the CATALINA_OPTS property, but still have the issue.

I have deployed it on AWS using the Confluence DC CloudFormation template.

All Linux systems. Running confluence 6.10.1

Please help.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published 7 hours ago in Confluence Cloud

Happy holidays from our team to yours!

Hi Community!  2018 was filled with changes for our team, both big and small, and we've taken a lot of time to both celebrate our wins and recognize areas of improvement. One thing that we're a...

86 views 0 11
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you