It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Getting error:"Unable to communicate with server. Saving is not possible at the moment."in

shiva pandey Oct 04, 2016

Hi ,

Whenever I am trying to create a new page in an existing space I am getting error :  "Unable to communicate with server. Saving is not possible at the moment.". Any help would be appreciated.

errorPage.PNG

30 answers

11 votes
Jonathan Kong Dec 06, 2016

I think I've fixed the issue by turning off Collaborative editing and Synchrony. I was noticing the drafting system having trouble, and taking a very long time before it was 'ready'.

Confluence administration > General Configuration > Under 'Administration' > Collaborative Editing

Aylin Kohls Jan 04, 2017

It seems that when time of response are not good, save not works under collaborative editing.

I turned off the feature and it worked!! thanks Jonathan!!!

Like Roelf Schlebusch likes this
Garnet Chaney Jan 08, 2017

I turned off just the plugin for Collaborative Editing.  I didn't see a separate setting for "Collaborative Editing"

Matt Drane Jan 10, 2017

We had the same issue but turning off Collaborative Editing solved the issue.

Chris Dahlem Jan 10, 2017

Thanks. Disabling Callobrative Editing has fixed the issue. Appears to be a problem with Confluence 6.0.3 though!

Emil Schlongs Jan 24, 2017

did the job! thanks!

C. M. Wettercrantz Feb 01, 2017

Plus one on that work around

Leticia Mooney Dec 20, 2017

I tried to find this fix in Confluence cloud but the pathway doesn't exist.

 

Is there another way to solve it for that instance?

Like Robert Wensley likes this
Adrian Wyssmann Feb 23, 2018

Any idea how to fix this but keep collaborative editing on?

Evy Lizárraga Aug 21, 2018

Any answer for this? I'd like to use Collaborative Editing as well. 

Florian Eichin Sep 17, 2018

I have the same problem - are there any further help?

6 votes
Martin Maat Feb 09, 2018

It turned out I was using emojis. In particular a hand that indicates a hands-on action to be performed: 👉

It is a plain valid Unicode character which gets displayed perfectly in draft mode. Yet it inhibits the page from being published, with the known misleading error.

Kurt Dodrill Apr 23, 2018

Removing a single smiley face emoji we had on a page solved this issue for us. Thanks.

Like Jesús Montelongo likes this

In an expand-field in a page edit, we removed a smiley, and that fiexed it for us. :-) Thanks for the hint.

Tim Colson Oct 25, 2018

Bingo. Same issue here. 

Rob Donoghue I'm New Here Apr 01, 2019

Fixed it for me, thank you. 

Marcel Pallarés Apr 02, 2019

The same here! Thank you :) 

4 votes
chander inguva Dec 08, 2016

For some reason, i see same issue in Confluence 5.10.7 Server 

3 votes
Chris Zach Dec 20, 2016

I don't have an answer, but here's what I'm seeing for symptoms, which agree with comments on this page from others.

  • Using Confluence Cloud.
  • Error occurs in Chrome, but not in Safari.
  • Error occurs on page with the % character.

Is there a JIRA ticket filed yet?

 

Bruce Cannon Dec 20, 2016

I filed an issue for Cloud, they say it got fixed.  % doesn't break for my pages anymore.  And I think they must have fixed for Server too, because I can now type it into this box!  If you are on Server and still have the issue, I think you should open a new ticket.  Here is the ticket I filed https://support.atlassian.com/servicedesk/agent/JST/issue/JST-242800 

Adam Norgaard Dec 22, 2016

Can confirm that this has been resolved on the Cloud version of confluence and Jira.  I can now edit these pages with the percent sign.  It only affected Chrome.

Bruce Cannon Dec 22, 2016

This problem is back for me on Cloud.  However I recently installed a beta version of Chrome (Canary) so this may be related.

Chris Zach Jan 05, 2017

Closing the loop: The problem for me was caused by the interaction with the LastPass Chrome extension. Not sure what the long-term resolution will be yet.

Like Senthil Subramanian likes this
Josh Ramos Jan 05, 2017

I can confirm. Lastpass is causing this error for me as well. I was able to disable the extension and after I was able to save a page.

 

Any update on a resolution for this? This has only just recently started happening. 

Roya Elison Jan 06, 2017

I'm having the same issue using Chrome and LassPass plugin. I filed a ticket with LastPass. They suggested updating the Autofill settings, but I have yet to get it working. 

https://lastpass.com/support.php?cmd=showfaq&id=8956

 

S Hoover Nov 02, 2017

Thanks for this thread for pointing me in the right direction. I had this symptom for a similar but not specifically identical reason.

  • Firefox 56.0.2
  • Confluence 6.0.6 on-prem (managed by us, not by Atlassian)
  • Not using LastPass on my client side
  • Not sure whether HipChat plugin is enabled on server side

In my case, there were no percent characters in the text. However, I had copied and pasted from an email from MS Outlook that contained two smile emojis. Suspecting those, I deleted just the two emojis and I was able to save my page.

Conclusion: Confluence hates special characters.

Kelly Arrey Jan 19, 2018

One of our users just encountered this, it turned out to be because he tried to save a page which included an emoji.

1 vote
Benjamin Saberin Oct 15, 2016

EDIT: After a day, the issue popped up again.  I dug through the logs and saw an odd HipChat plugin error.  After disabling all the HipChat addons, 5.10.6 works for us.  I'm assuming this was the original issue.


I experienced this issue with Confluence Server version 5.10.7.  "Upgrading' to 5.10.6 resolved the issue for me.

My application Server is Linux.  DB Server is MS SQL 2012.

Symptoms: After upgrading to 5.10.7 I saw the error above (and many other errors) whenever attempting to Save or Import.  The drafts were saved to the DB (I found this by querying SQL directly).  I also had odd and frequent heartbeat errors.  

Solution: I downloaded 5.10.6 and installed it as an upgrade.  The problem immediately resolved itself.

Note: This was the second major issue I had with 5.10.7.  Last night I installed it and the upgrade corrupted my DB.  I restored the Application Server from a snapshot, and the DB from a backup.  Today I ran the installation again and thought things went well (everything seemed to work, but saving failed).

Conclusion: I suspect there are problems with https://www.atlassian.com/software/confluence/downloads/binary/atlassian-confluence-5.10.7-x64.bin

 

david weng2 Oct 19, 2016

Indeed, disabling  HipChat  add-ons solved my problem.!!

Benjamin Saberin Oct 19, 2016

I'm very glad it helped!

I found this especially frustrating because we do not use HipChat integration with Confluence (we for Jira).

Are you running 5.10.7 or 5.10.6?  I want to upgrade to 5.10.7 this weekend if all I need to do is disable HipChat add-ons.

david weng Oct 19, 2016

Hey, We're running 5.10.7.

It seems that the HipChat integration plugins caused this problem.

 

PS i needed to create a second account since i already posted twice in 24 hours lol...

 

Anyways thank you for the solution, helped me a lot smile 

Same Error in 6.0.1 - HipChat Plugins are OFF and it still does not want to save some pages.

Contribyte Atlassian Nov 22, 2016

I have several different instances of 6.0.1. All of the are suffering on this problem.

David Nov 27, 2016

Same as Jiraconfluence Solutionmgm sIT. How did you solve your problem ?

 

 

Help Desk Dec 02, 2016

Spanking new install with this same problem.

Thomas Gorence Dec 08, 2016

Same issue here, seemed to have started with an update to 6.0.1

Bruce Cannon Dec 08, 2016

I am experiencing this same problem.  

  1. When I try to enter edit mode for any page, instantly get  "taking longer than usual, try reloading the page."  
  2. If I wait, it never loads.  
  3. If I reload, get page in edit mode.  
  4. But cannot save changes; get an endlessly repeating cycle of first "unable to communicate with server" followed after a few seconds by "you're back in business".
  5. If I hit Update, this process repeats.  Forever.  
  6. After experimenting with this whole cycle a few times, I get "Something went wrong after loading the editor. Copy your unsaved changes and refresh the page to keep editing."  

Am on Cloud.

Bruce Cannon Dec 08, 2016

I don't know if I have found the smoking gun for others, or a bug isolated to my instance, or my browser, or what...

But here's what I found after a few hours of trying to track down the source of the problem (why are some pages editable, while others are not?  Is there markup, invisible codes, or table, macros, or even visible characters that are causing problems?) 

Eventually I found something inexplicable.  Any page I eliminate the percent character from becomes savable again!  And am able to isolate it and reproduce it too.  All the pages which were saved, but when edited become unsavable, I have been able to recover by editing out that character. 

Even stranger, I can create a new blank page, title it "Test" or whatever, and put no characters on the page other than the percent character, and it will not save.  I can even create a new page, with zero characters on it, title the page with the percent character, and it won't save.

How weird is that?  Can someone else with this problem try it and report back?

Edit: I don't know if this is a clue that what I am seeing is browser related, or a clue that it is a Confluence bug and Atlassian Answers is built on Confluence, but:  I originally wrote this note with "the percent character" replaced with the percent character itself, and this comment would not post!

Olly Cruickshank Dec 09, 2016

Bruce - you're right, i can't save pages with the percentage character in them.

This is in Confluence 5.10.1.

Anyone know if a later version fixes this?

Bruce Cannon Dec 09, 2016

Hi Oliver:

I was excited that we had confirmed that it was a Confluence issue, so could pass to Atlassian for solving.

But before I opened a support request I tried it in Safari.  Unfortunately, pages open, edit and save fine in Safari, with the percent character.  

Then when I go back to Chrome, and try and edit that page into which I had inserted the percent character, it fails again.

So now what does this mean?  Where does the problem lie?

Bruce

Dan Rumney Dec 09, 2016

I see this also... it's worth noting that it's not just content that can contain percent characters... some macros will also contain them (like Section macros).

I also saw this when I had a Table layout set to "Responsive". I couldn't save it until I set it to "Fixed width"... probably a percent CSS setting or something.

Thanks for the Safari tip.

Dan Rumney Dec 09, 2016

And it turns out that the problems exists here too! Can't use the actual percent character.

Dan Rumney Dec 09, 2016

I dug further.

3 users, all with the same version of Chrome: A, B, C

A is an admin and sees this issue
B is an admin and does not see this issue
C is not an admin and does not see this issue.

When I compare the HTML source of these three users all editing the same page, I obviously see diffs. When you remove the admin related diffs, the timestamp/key related diffs and the user name related diffs, something stood out:

Issue seen:

<meta name="ajs-discovered-plugin-features" content="{&quot;com.atlassian.confluence.plugins.confluence-jira-metadata&quot;:[&quot;linked-issues-dropdown&quot;,&quot;inline-tasks-flag&quot;],&quot;com.atlassian.confluence.plugins.confluence-dashboard&quot;:[&quot;dialog&quot;,&quot;tour-step-sidebar&quot;,&quot;transition-saved-for-later&quot;,&quot;tips&quot;],&quot;com.atlassian.confluence.plugins.confluence-hipchat-integration-plugin&quot;:[&quot;hipChatServerIntegration&quot;]}">

Issue not seen:

<meta name="ajs-discovered-plugin-features" content="{&quot;com.atlassian.confluence.plugins.confluence-jira-metadata&quot;:[&quot;linked-issues-dropdown&quot;],&quot;com.atlassian.confluence.plugins.confluence-hipchat-integration-plugin&quot;:[&quot;hipChatServerIntegration&quot;]}">

Of course, it could be other things, but that's what I am seeing

 

Dan Rumney Dec 09, 2016

That, and in the failing instance, I see

 data-base-url=&quoquot;https://confluence.example.com/confluence&quot;

in the TinyMCE textarea and I don't see that in the working instances

Adam Norgaard Dec 15, 2016

Confirmed issue with the percent sign in confluence and JIRA using Chrome.  It just will not save.

Olly Cruickshank Jan 03, 2017

Disabling lastpass (or going into incognito mode) fixes the issue for me.

Dan Rumney Jan 03, 2017

I checked and confirmed that I see the same behaviour - seems to be some kind of interaction with LastPass

Brian Jester Jan 03, 2017

Thank you Oliver and Dan for finding the LastPass connection!

Bruce Cannon Jan 03, 2017

Great find!  Over in the LastPass forums much discussion on the discovery that disabling the LastPass chrome extension is the only way to get Google Inbox to send messages.  

So Lastpass+Confluence is apparently not an isolated interaction but a more general disruption by that extension.  

I'm still puzzled about the interaction between LastPass and percent signs in Confluence though.  I should check to see if mail that doesn't send has a percent sign in it smile 

1 vote
Mike Hamilton Oct 19, 2017

If you have the add-on "Adaptavist Selectacular", disable it. This fixed it for me after upgrading from 5.9 to 6.3.4

Austin Smith Oct 10, 2018

disabling this plugin fixed for me as well!

1 vote
Barbara Bazemore Kiszka Jan 10, 2018 • edited

I saw this error repeatedly when saving one particular page. When editing the characters "->" changed to a new special symbol. After I removed the symbol the page saved successfully.

I agree with @S Hoover above, Confluence does not like special characters.

1 vote
Marcel Klapwijk Mar 30, 2018

On Confluence 6.8.0 problems saving large tables generated in confluence markup. Disabling 'Confluence Hipchat Plugin' seems to be still the working solution. 

0 votes
Chuck Daniels Oct 11, 2016

I'm experiencing the same problem!

0 votes
Yann Barrault Oct 11, 2016

Same issue for me sad

0 votes
Lewis Richards Oct 12, 2016

I've got the same issue today with a brand new install

0 votes
Marcel Woschek Oct 13, 2016

I get this message when I try to edit a page I generated by a custom plugin. Only on the generated pages though...

0 votes
david weng2 Oct 19, 2016

same issue for me.

0 votes
Rajiv Kanaujia Dec 12, 2016

same here

0 votes
Eric Morot Dec 15, 2016

This was a frustrating problem however it was resolved when I noticed Outlook was prompting for my network password. After entering my network password in Outlook I could publish the page.  

0 votes
Silas Mächler Dec 16, 2016

same here. but it seems like i'm the only user in our company who has this problem.

0 votes
SOPORTE INFORMATICA Dec 21, 2016

We have the same problem!

0 votes
Brian Jester Dec 23, 2016

Switched from Chrome to Safari, and it saves now.  The Confluence wiki page doesn't have any percent symbols, and we don't have the HipChat plugin.

0 votes
Russell Shirley Jan 03, 2017

Still an issue.  Running hosted Confluence and local hipchat.   No % signs in document.  Confluence still does not allow saving when using Chrome. 

0 votes
Garnet Chaney Jan 08, 2017

Seeing this on a brand new install of Confluence 6.0.3 server, nothing customized yet.

Installed on Centos 7 virtual machine that is vanilla GUI install, with Firefox.  "Can't save changes" came up in the status bar of the editor almost immediately upon clicking edit.  Running the wiki and accessing it as   http://localhost:8090

Solution: Had to disable Confluence Collaborative Editor Plugin.

0 votes
Craig Brand Jan 10, 2017

We've upgraded to V 6.0.3 today and this is happening to us. Grrrr!

0 votes
Daniel Guidry Jan 10, 2017

I just upgraded from 5.9.4 to 6.0.3 today and we began seeing this exact issue. I disabled the collaborative editing function as some other posters did and it resolved the problem.  Looks like an issue there that Atlassian will need to sort out for the next update.

Yves SAMEN Mar 03, 2017

It worked for me. Hope we'll have an update from @atlassian-consulting@e-core.com very soon

0 votes
Froilan Ocampo Jan 13, 2017

I'm getting the same problem ever since I upgraded to 6.0.3

With Collaborative Editing ON

  • error when trying to save "Unable to communicate with server.  Saving is not possible at the moment"

With Collaborative Editing LIMITED

  • cannot move existing pages
  • cannot rename existing pages
  • cannot make inline comments

 

I just tried disabling the HipChat plugins as others have suggested, but that doesn't seem to have any effect.

At the moment, I am having to flip the Collaborative Editing setting back and forth just so our users can do the work they need. 

 

 

Froilan

 

 

0 votes
Lisa Gordon Feb 01, 2017

I see it with 5.10.8.  I use Chrome.  I frequently also have errors about having a saved draft to merge even though I can see my previous save was ok.  Anyone else see that issue?

0 votes
tracy grygiel (Finn) Feb 07, 2017

I'm experiencing the same problem in IE 11.  I'm running Confluence on their cloud (hosted).  I am trying out different wikis for my company and if this doesn't resolve, I'll have to go to another solution. It worked well for me at another organization.  I haven't heard back from them at all (disappointing).  sad 

Suggest an answer

Log in or Sign up to answer
This widget could not be displayed.
This widget could not be displayed.
Community showcase
Published in Confluence

Confluence CVEs and common questions

Two vulnerabilities have been published for Confluence Server and Data Center recently: March 20, 2019 CVE-2019-3395 / CVE-2019-3396 April 17, 2019 CVE-2019-3398 The goal of this article is...

951 views 0 19
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you