Getting error:"Unable to communicate with server. Saving is not possible at the moment."in

Hi ,

Whenever I am trying to create a new page in an existing space I am getting error :  "Unable to communicate with server. Saving is not possible at the moment.". Any help would be appreciated.

errorPage.PNG

28 answers

I think I've fixed the issue by turning off Collaborative editing and Synchrony. I was noticing the drafting system having trouble, and taking a very long time before it was 'ready'.

Confluence administration > General Configuration > Under 'Administration' > Collaborative Editing

It seems that when time of response are not good, save not works under collaborative editing.

I turned off the feature and it worked!! thanks Jonathan!!!

I turned off just the plugin for Collaborative Editing.  I didn't see a separate setting for "Collaborative Editing"

We had the same issue but turning off Collaborative Editing solved the issue.

Thanks. Disabling Callobrative Editing has fixed the issue. Appears to be a problem with Confluence 6.0.3 though!

did the job! thanks!

Plus one on that work around

I tried to find this fix in Confluence cloud but the pathway doesn't exist.

 

Is there another way to solve it for that instance?

Any idea how to fix this but keep collaborative editing on?

For some reason, i see same issue in Confluence 5.10.7 Server 

I don't have an answer, but here's what I'm seeing for symptoms, which agree with comments on this page from others.

  • Using Confluence Cloud.
  • Error occurs in Chrome, but not in Safari.
  • Error occurs on page with the % character.

Is there a JIRA ticket filed yet?

 

I filed an issue for Cloud, they say it got fixed.  % doesn't break for my pages anymore.  And I think they must have fixed for Server too, because I can now type it into this box!  If you are on Server and still have the issue, I think you should open a new ticket.  Here is the ticket I filed https://support.atlassian.com/servicedesk/agent/JST/issue/JST-242800 

Can confirm that this has been resolved on the Cloud version of confluence and Jira.  I can now edit these pages with the percent sign.  It only affected Chrome.

This problem is back for me on Cloud.  However I recently installed a beta version of Chrome (Canary) so this may be related.

Closing the loop: The problem for me was caused by the interaction with the LastPass Chrome extension. Not sure what the long-term resolution will be yet.

I can confirm. Lastpass is causing this error for me as well. I was able to disable the extension and after I was able to save a page.

 

Any update on a resolution for this? This has only just recently started happening. 

I'm having the same issue using Chrome and LassPass plugin. I filed a ticket with LastPass. They suggested updating the Autofill settings, but I have yet to get it working. 

https://lastpass.com/support.php?cmd=showfaq&id=8956

 

Thanks for this thread for pointing me in the right direction. I had this symptom for a similar but not specifically identical reason.

  • Firefox 56.0.2
  • Confluence 6.0.6 on-prem (managed by us, not by Atlassian)
  • Not using LastPass on my client side
  • Not sure whether HipChat plugin is enabled on server side

In my case, there were no percent characters in the text. However, I had copied and pasted from an email from MS Outlook that contained two smile emojis. Suspecting those, I deleted just the two emojis and I was able to save my page.

Conclusion: Confluence hates special characters.

One of our users just encountered this, it turned out to be because he tried to save a page which included an emoji.

2 votes

It turned out I was using emojis. In particular a hand that indicates a hands-on action to be performed: 👉

It is a plain valid Unicode character which gets displayed perfectly in draft mode. Yet it inhibits the page from being published, with the known misleading error.

Removing a single smiley face emoji we had on a page solved this issue for us. Thanks.

In an expand-field in a page edit, we removed a smiley, and that fiexed it for us. :-) Thanks for the hint.

EDIT: After a day, the issue popped up again.  I dug through the logs and saw an odd HipChat plugin error.  After disabling all the HipChat addons, 5.10.6 works for us.  I'm assuming this was the original issue.


I experienced this issue with Confluence Server version 5.10.7.  "Upgrading' to 5.10.6 resolved the issue for me.

My application Server is Linux.  DB Server is MS SQL 2012.

Symptoms: After upgrading to 5.10.7 I saw the error above (and many other errors) whenever attempting to Save or Import.  The drafts were saved to the DB (I found this by querying SQL directly).  I also had odd and frequent heartbeat errors.  

Solution: I downloaded 5.10.6 and installed it as an upgrade.  The problem immediately resolved itself.

Note: This was the second major issue I had with 5.10.7.  Last night I installed it and the upgrade corrupted my DB.  I restored the Application Server from a snapshot, and the DB from a backup.  Today I ran the installation again and thought things went well (everything seemed to work, but saving failed).

Conclusion: I suspect there are problems with https://www.atlassian.com/software/confluence/downloads/binary/atlassian-confluence-5.10.7-x64.bin

 

Indeed, disabling  HipChat  add-ons solved my problem.!!

I'm very glad it helped!

I found this especially frustrating because we do not use HipChat integration with Confluence (we for Jira).

Are you running 5.10.7 or 5.10.6?  I want to upgrade to 5.10.7 this weekend if all I need to do is disable HipChat add-ons.

Hey, We're running 5.10.7.

It seems that the HipChat integration plugins caused this problem.

 

PS i needed to create a second account since i already posted twice in 24 hours lol...

 

Anyways thank you for the solution, helped me a lot smile 

Same Error in 6.0.1 - HipChat Plugins are OFF and it still does not want to save some pages.

I have several different instances of 6.0.1. All of the are suffering on this problem.

Same as Jiraconfluence Solutionmgm sIT. How did you solve your problem ?

 

 

Spanking new install with this same problem.

Same issue here, seemed to have started with an update to 6.0.1

I am experiencing this same problem.  

  1. When I try to enter edit mode for any page, instantly get  "taking longer than usual, try reloading the page."  
  2. If I wait, it never loads.  
  3. If I reload, get page in edit mode.  
  4. But cannot save changes; get an endlessly repeating cycle of first "unable to communicate with server" followed after a few seconds by "you're back in business".
  5. If I hit Update, this process repeats.  Forever.  
  6. After experimenting with this whole cycle a few times, I get "Something went wrong after loading the editor. Copy your unsaved changes and refresh the page to keep editing."  

Am on Cloud.

I don't know if I have found the smoking gun for others, or a bug isolated to my instance, or my browser, or what...

But here's what I found after a few hours of trying to track down the source of the problem (why are some pages editable, while others are not?  Is there markup, invisible codes, or table, macros, or even visible characters that are causing problems?) 

Eventually I found something inexplicable.  Any page I eliminate the percent character from becomes savable again!  And am able to isolate it and reproduce it too.  All the pages which were saved, but when edited become unsavable, I have been able to recover by editing out that character. 

Even stranger, I can create a new blank page, title it "Test" or whatever, and put no characters on the page other than the percent character, and it will not save.  I can even create a new page, with zero characters on it, title the page with the percent character, and it won't save.

How weird is that?  Can someone else with this problem try it and report back?

Edit: I don't know if this is a clue that what I am seeing is browser related, or a clue that it is a Confluence bug and Atlassian Answers is built on Confluence, but:  I originally wrote this note with "the percent character" replaced with the percent character itself, and this comment would not post!

Bruce - you're right, i can't save pages with the percentage character in them.

This is in Confluence 5.10.1.

Anyone know if a later version fixes this?

Hi Oliver:

I was excited that we had confirmed that it was a Confluence issue, so could pass to Atlassian for solving.

But before I opened a support request I tried it in Safari.  Unfortunately, pages open, edit and save fine in Safari, with the percent character.  

Then when I go back to Chrome, and try and edit that page into which I had inserted the percent character, it fails again.

So now what does this mean?  Where does the problem lie?

Bruce

I see this also... it's worth noting that it's not just content that can contain percent characters... some macros will also contain them (like Section macros).

I also saw this when I had a Table layout set to "Responsive". I couldn't save it until I set it to "Fixed width"... probably a percent CSS setting or something.

Thanks for the Safari tip.

And it turns out that the problems exists here too! Can't use the actual percent character.

I dug further.

3 users, all with the same version of Chrome: A, B, C

A is an admin and sees this issue
B is an admin and does not see this issue
C is not an admin and does not see this issue.

When I compare the HTML source of these three users all editing the same page, I obviously see diffs. When you remove the admin related diffs, the timestamp/key related diffs and the user name related diffs, something stood out:

Issue seen:

<meta name="ajs-discovered-plugin-features" content="{&quot;com.atlassian.confluence.plugins.confluence-jira-metadata&quot;:[&quot;linked-issues-dropdown&quot;,&quot;inline-tasks-flag&quot;],&quot;com.atlassian.confluence.plugins.confluence-dashboard&quot;:[&quot;dialog&quot;,&quot;tour-step-sidebar&quot;,&quot;transition-saved-for-later&quot;,&quot;tips&quot;],&quot;com.atlassian.confluence.plugins.confluence-hipchat-integration-plugin&quot;:[&quot;hipChatServerIntegration&quot;]}">

Issue not seen:

<meta name="ajs-discovered-plugin-features" content="{&quot;com.atlassian.confluence.plugins.confluence-jira-metadata&quot;:[&quot;linked-issues-dropdown&quot;],&quot;com.atlassian.confluence.plugins.confluence-hipchat-integration-plugin&quot;:[&quot;hipChatServerIntegration&quot;]}">

Of course, it could be other things, but that's what I am seeing

 

That, and in the failing instance, I see

 data-base-url=&quoquot;https://confluence.example.com/confluence&quot;

in the TinyMCE textarea and I don't see that in the working instances

Confirmed issue with the percent sign in confluence and JIRA using Chrome.  It just will not save.

Disabling lastpass (or going into incognito mode) fixes the issue for me.

I checked and confirmed that I see the same behaviour - seems to be some kind of interaction with LastPass

Thank you Oliver and Dan for finding the LastPass connection!

Great find!  Over in the LastPass forums much discussion on the discovery that disabling the LastPass chrome extension is the only way to get Google Inbox to send messages.  

So Lastpass+Confluence is apparently not an isolated interaction but a more general disruption by that extension.  

I'm still puzzled about the interaction between LastPass and percent signs in Confluence though.  I should check to see if mail that doesn't send has a percent sign in it smile 

I saw this error repeatedly when saving one particular page. When editing the characters "->" changed to a new special symbol. After I removed the symbol the page saved successfully.

I agree with @S Hoover above, Confluence does not like special characters.

I'm experiencing the same problem!

Same issue for me sad

I've got the same issue today with a brand new install

I get this message when I try to edit a page I generated by a custom plugin. Only on the generated pages though...

same issue for me.

This was a frustrating problem however it was resolved when I noticed Outlook was prompting for my network password. After entering my network password in Outlook I could publish the page.  

same here. but it seems like i'm the only user in our company who has this problem.

We have the same problem!

Switched from Chrome to Safari, and it saves now.  The Confluence wiki page doesn't have any percent symbols, and we don't have the HipChat plugin.

Still an issue.  Running hosted Confluence and local hipchat.   No % signs in document.  Confluence still does not allow saving when using Chrome. 

Seeing this on a brand new install of Confluence 6.0.3 server, nothing customized yet.

Installed on Centos 7 virtual machine that is vanilla GUI install, with Firefox.  "Can't save changes" came up in the status bar of the editor almost immediately upon clicking edit.  Running the wiki and accessing it as   http://localhost:8090

Solution: Had to disable Confluence Collaborative Editor Plugin.

We've upgraded to V 6.0.3 today and this is happening to us. Grrrr!

I just upgraded from 5.9.4 to 6.0.3 today and we began seeing this exact issue. I disabled the collaborative editing function as some other posters did and it resolved the problem.  Looks like an issue there that Atlassian will need to sort out for the next update.

It worked for me. Hope we'll have an update from @atlassian-consulting@e-core.com very soon

I'm getting the same problem ever since I upgraded to 6.0.3

With Collaborative Editing ON

  • error when trying to save "Unable to communicate with server.  Saving is not possible at the moment"

With Collaborative Editing LIMITED

  • cannot move existing pages
  • cannot rename existing pages
  • cannot make inline comments

 

I just tried disabling the HipChat plugins as others have suggested, but that doesn't seem to have any effect.

At the moment, I am having to flip the Collaborative Editing setting back and forth just so our users can do the work they need. 

 

 

Froilan

 

 

I see it with 5.10.8.  I use Chrome.  I frequently also have errors about having a saved draft to merge even though I can see my previous save was ok.  Anyone else see that issue?

I'm experiencing the same problem in IE 11.  I'm running Confluence on their cloud (hosted).  I am trying out different wikis for my company and if this doesn't resolve, I'll have to go to another solution. It worked well for me at another organization.  I haven't heard back from them at all (disappointing).  sad 

If you have the add-on "Adaptavist Selectacular", disable it. This fixed it for me after upgrading from 5.9 to 6.3.4

On Confluence 6.8.0 problems saving large tables generated in confluence markup. Disabling 'Confluence Hipchat Plugin' seems to be still the working solution. 

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Tuesday in Confluence

We want to see the templates you've created in Confluence!

Hi Community, Jessica here from the Confluence Product Marketing team!  July’s community challenge is all about sharing pictures  — and as an extension of our first post on what ...

375 views 16 9
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you