Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Getting Incorrect Isolation level error for Confluence setup

Hi Team,

Request you to please assist in fixing the below error for confluence setup.

"Your database must use 'READ-COMMITTED' as the default isolation level."

I have followed all the instructions specified on this link. 

https://confluence.atlassian.com/confkb/confluence-fails-to-start-and-throws-mysql-session-isolation-level-repeatable-read-is-no-longer-supported-error-241568536.html

Thanks a lot.

Regards,

Tanishka S Chotwani

3 answers

1 vote
Minh Tran Atlassian Team Apr 04, 2018

@eClerx Orion What instruction did you follow? If you modified my.cnf, you need to restart MySQL Server to get it affected.

Otherwise, you can just run these SQL command for your mysql account that is used to connect to database

SET [SESSION | GLOBAL] TRANSACTION ISOLATION LEVEL READ COMMITTED

See https://dev.mysql.com/doc/refman/5.5/en/set-transaction.html for further information 

0 votes
AnnWorley Atlassian Team Apr 03, 2018

Hi,

Since this is an initial setup, please refer back to the doc you linked and try:

or new installations of Confluence, configure the JDBC string as follows to set the sessionVariable to enforce READ-COMMITTED during the initial setup wizard:

&sessionVariables=tx_isolation='READ-COMMITTED'


e.g. jdbc:mysql://127.0.0.1:3306/confdb?sessionVariables=tx_isolation='READ-COMMITTED'

To restart the setup wizard, delete confluence_home/confluence.cfg.xml then restart Confluence. 

 

Deleted user Aug 28, 2019

This is perfect.  When setting up DB, just select the "By connection string" option instead of the "Simple" option.

Got around this by editing /etc/mysql/my.cnf and adding

[mysqld]
transaction-isolation=READ-COMMITTED

 

Then I restarted mysql.

Hi Aviv.

Thanks a lot for adding solution for this quetion. I was stuck same and by mentioning transaction-isolation=Read-committed resolved the issue.

 

Regards,

Shahebaaz

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

What do you think is the most *delightful* Confluence feature? Comment for a prize!

- Create your own custom emoji 🔥 - "Shake for Feedback" on mobile 📱 - An endless supply of GIFs via GIPHY 🤩 Is there anything quite as nice as a pleasant surprise? Comment below with what...

463 views 24 9
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you