Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,458,181
Community Members
 
Community Events
176
Community Groups

Forcing columns (column macro) to be as wide as their percentages

Edited

Using the column macro, I created a page with 5 columns set to 19% each, with a 1% column serving as a spacer between each of them. 

So it's 9 columns: 19%   1%   19%   1%   19%   1%   19%   1%   19%

The problem I'm having is that the columns always shrink to be as narrow as the widest text in any of them.  Instead, I'd like them to take up the percentage of the page I've specified, regardless of whether the text in the column fills that space.

Immediately below is how that renders.  As you can see, the 9 columns do not fill 99% of the horizontal space even though 99% is the sum of the specified column widths. 

Collapsed1.JPG

After some poking around, what became clear is that Confluence is narrowing the columns so that each is only as wide as the widest text in any of the 19% columns.  What I want is to force the columns to be the width (in percent) that I specified.  I don't want to specify width in pixels because then the column widths won't scale up/down when a user expands/shrinks their browser window.

I figured out that if I put text into any one of the columns that is so long that it would wrap at any reasonable browser width, then this forces all the columns (not just that one) to fill the 99% specified. This is how I want it to appear - as shown in the image at the bottom of this post.

As a hack/workaround I'm putting white text on a white background at the bottom of one of the columns.  The invisible text does fix the formatting, but it's a clunky solution that leaves garbage text on my page that becomes visible any time a user hits ctrl-a. 

Is there a non-hack way of forcing columns that are specified in percentages to actually expand to the specified percentage?

Is this a bug in confluence's implementation of columns?  Or should something like "Enforce specified % width" be an option/check box in the column macro?

NotCollapsed1.JPG

0 answers

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events